Problems with proxy redirect

Hello community,
i am a complete newbie to this and i set an account on cloudflare because i have a 3th party service that i need to setup to my domain. This worked just fine. But i want to keep this service a secret to my competitors and so i switch on the proxy option, where the proxy is exactly doing what i want, only the 3th party website doesn’t work anymore.

Is there something i need to do in addition?
setup a record to ip address and in my hosting environment i set the name servers to cloudflare. Waited until all was working, but the website isn’t reachable. When i turn off the proxy it works, but than i people see the endpoint which i want to prevent.

hopefully somebody knows a working solution.

thanks in advance for your help

Can you tell us what Port you want to use for this application and what error are you seeing when you call the site while it does not work?

Hi Martin,

It think it is standard 443 and 80 When I go to the website without proxy, it works just fine. It is https traffic.

Does this make any sense or must I ask the vendor of the platform what ports need to be open. But as far as I know it is just https traffic.

Hi Martin,

The other application gives this message

Which means: The site cannot deliver a secure connection

Non supported protocol

The client and server don’t support general ssl protocolversion or codingsuite (translated to my best ability)

But the problem seems to a setup in security on the CF environment.

Thanks for your help

Please just one problem per thread.

snp.ee is not using CloudFlares NameServers but Amazones one.

Just a CNAME points to a CloudFlares IP, this is just possible for Business & Enterprise users. Are you a Business or Enterprise user? If not you have to move with the WHOLE domain (all NameServers) to the NameServers CloudFlare provided to you, to use it.
Please read this:

As you get a Error 1001 you will find what it means in the docs.

Hi Martin,

I just deleted everything and setup all over again. I will wait for all services to be populated and once that Is done I let you know.

Thanks so far for your help

Hi Martin,

Just received an email from cloudflare that the name servers are setup correctly.

But I am still unable to go to the domain as long as the proxy is active. Any idea what can cause this? I don’t see any settings wrong in the setup.

Looking forward to hear if you have a solution for me.

Lets do this more structured.

  1. what domain is the problem not related to? (snp.ee or funnelizer.ddm.tools?)
  2. yes I can see that NameServers are set up correct. But they have not been set up before

When I call snp.ee now I do no longer get your original Error but “DNS_PROBE_FINISHED_NXDOMAIN” therefor I would recommend you reading this:

Also: can you post a Screenshot of the DNS section of your Dashboard? (censor last digits of IPs is ofc ok)

1 Like

Hi Martin,

Lets do this more structured.

image003.jpg

Hi Martin,

Can you check if you can open https://snp.ee/popup

On desktop and mobile? I think it is working correct now.

Would be great

image002.jpg

Sorry Martin, just test on another phone and it is still not working :frowning:

image002.jpg

image004.jpg

Hi Martin,

Sorry for all the mails, but I was able to figure out why it is not working.

When I am on desktop of mobile over WiFi it works, but if I use the mobile provider it is giving an error, seems that something still isn’t setup correctly.

Question is what?

image002.jpg

ATM I see a “ERR_TOO_MANY_REDIRECTS” Error which is redirecting in a loop from HTTP to HTTPS to HTTP again.

I turned off the https on the server site and use the security from CF.

Now it seems to work. But mobile redirects to unsecure site

Ton Tognolli

Tognology

Outlook for Android downloaden

That’s because of:

Is the URL for Mobile different from the URL for Desktop?

Hi There,

Thanks for you involvement and help.

I run some tests and what I noticed it that on mobile the site is unsecure. But only if I go via the network of the mobile provider. On Wifi it goes to a secure website.

On desktop it goes to a secured site. The link is the same link in all cases. And also the website is the same.

Maybe it is a limitation of the mobile network.

image002.jpg