New WordPress Plugin Update Crashed Site


When I updated the Cloudflare Plugin on WordPress from version 4.4 to the latest, my staging site crashed:
I am unable to access wp-admin anymore to revert back to a previous version.
I moved the cloudflare plugin directory/folder to trash from cPanel>File Manager, but the problem wasn’t fixed.

Please advise.

When I try to open it, it gives me “404 not found”.
Am I trying the right addres or wrong one?

May I ask have you tried temporarly renaming the “plugins” folder, so it shouldn’t load any plugin and let you into the WP admin dashboard?
Furthermore, enabling or copy-paste each plugin, to debug if there could be some kind of a conflict?
Also, installing the new official Cloudflare for WordPress plugin?

Yes exactly, the 404 error started happening when I updated the plugin.

On my side I keep getting: This page isn’t working right now redirected you too many times.

I am sure the problem is from the updated Cloudflare plugin, at this point I just would like to regain access to the site and dashboard. I thought deleting from File Manager would resolve the issue, but it doesn’t seem so…

I am really sorry to hear that, but also afraid this is not the only issue here (Cloudflare plugin), as the plugin does not change anything regarding WordPress either it’s backend structure, URLs, database, etc. as far as I used it.

May I ask what SSL option have you got selected at Cloudflare Dashboard, the SSL/TLS tab?

Have you checked your permalink structure in database?
Have you correctly added staging as a sub-domain DNS record type A to your domain at Cloudflare dashboard the DNS tab?

Do you have any Page Rules for your (sub)domain applied at Cloudflare?

Yes, everything was working fine before I updated the CloudFlare plugin from version 4.4, as soon as I updated it, it caused all these issues.

I have the Flexible SSL/TLS option, I didn’t change anything within the permalink structure so it shouldn’t be affected; if you check the main site, where I haven’t pushed any updates yet, it is working fine.
The DNS record is Type A and as I mentioned it was working just fine with version 4.4 of the plugin.
I didn’t set any Page Rules.

This option is known to create issues just like redirection loops, mixed content, etc.

You should get an SSL certificate and set it on Full (Strict).

If you do not have an SSL certificate for your domain (and www sub-domain and other sub domains if so, excluding the “e-mail”), you could go with Cloudflare Origin CA Certificate.

A great article about setting up an SSL for your domain at Cloudflare can be read in as a step-by-step instruction on the below article:

Below are some suggestions how to troubleshoot or check the settings regarding the SSL at Cloudflare:

Available and usefull options at Cloudflare dashboard:

Maybe this is the issue?:

I am using Flexible because it was causing problems with Full, my hosting provider suggested to change it to Flexible, and it worked fine before the plugin update.

It seems other people had that same issue, my question is, how can I revert back, or gain back control of wp-admin?

Thank you.

Yes, apparently they encrypt it on their end as well, so Full causes some kind of conflict.

Thank you for your suggestion, but this is not the issue that I am trying to resolve at this point.
I need to regain access to the admin dashboard on the staging site, do you have any suggestions for that?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.