Internal server error 500

Hi!

I have been using cloudflare on my site for a year. So far there has been no problem, but now I have run into a complete anomaly.

my site: https://csomagnet.hu

First load home page: get error code 500 - internal server error
After (2.-3-4.-5.) reload the mainpage works correctly.

Any subpage works perfectly anytime.

curl -i https:// csomagnet.hu
HTTP/2 500
date: Sat, 25 Apr 2020 23:05:43 GMT
content-type: text/html
content-length: 1118
set-cookie: __cfduid=d6d3b0e817c0238f1a1133c4e516bab401587855943; expires=Mon, 25-May-20 23:05:43 GMT; path=/; domain=.csomagnet.hu; HttpOnly; SameSite=Lax; Secure
last-modified: Tue, 31 Mar 2020 13:59:58 GMT
etag: “45e-5a226fbaefeb1”
ms-author-via: DAV
cache-control: s-maxage=10
strict-transport-security: max-age=15552000; includeSubDomains; preload
cf-cache-status: DYNAMIC
expect-ct: max-age=604800, report-uri=“https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct
x-content-type-options: nosniff
server: cloudflare
cf-ray: 589bb5dec8c5d3ff-BUD
alt-svc: h3-27=":443"; ma=86400, h3-25=":443"; ma=86400, h3-24=":443"; ma=86400, h3-23=":443"; ma=86400
cf-request-id: 02552fff3d0000d3ff8fb4e200000001

I used Plesk, nginx, apache, ModPageSpeed. The server configuration is unchanged.
I recognised this problem in Incognito window, curl command, webpagetest, google page insight, gtmetrix etc…
The server error log is empty… I do not use a custom rule for the home page. I turn off ModPagespeed, I modified / turned off any options and comibantions (Cace, hsts, http2, performance disable, firewall, minimum tls, tls 1.3), Network settings,the result is the same.

Any idea?

Thanks for your reply

That’s mostly an issue with the origin server. Is the 500 error branded with “cloudflare” or “cloudflare-nginx”?

Thank you for your reply. The problem was on the server configuration.

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.