Error 521 wordpress-cloudflare connection

After re-installing wordpress, the domain is not accessing HTTPS anymore.

What is the domain name? ****

Have you searched for an answer? yes

Please share your search results url: 521

When you tested your domain using the Cloudflare Diagnostic Center, what were the results?

HTTPS 400 and above

Describe the issue you are having:

1 - i managed to install wordpress using docker images and issued certificates to the domain, it all went well, but I discovered docker images for AMR64 are hard to find. So I started another instance and installed wordpress without docker on:
-Ubuntu 22.04/arm64 - remote instance.

So far, I only managed to configure wp on the IP. When I open the domain it returned the following results:

- Err_connection_refused (when Cloudflare was paused)
- 521 server is down (when Cloudflare was enabled on complete and full TLS)
- A no html page displaing the wp text and links content. (when Cloudflare is enabled on flex)

There is a CA issued by Cloudflare 18 days prior to this new install, which was automatically placed as I installed wp. I haven’t yet configured Nginx to connect SSL certificates, only opened UFW to ports both v4 and v6.

What steps have you taken to resolve the issue?

**1. Changed firewall, enabled, disabled, allowed Nginx to all ports, all CDIR are 0.0.0.0/0 on my server so acceping all IPs, besides, this set up was working well when installed with docker. **
2. Tried all tips on Cloudflare document tips for 521
3. Read wordpress-Cloudflare plugin documentation on Cloudflare site, I am affraid it is not yet the case to install the plugin, but to have the certificate key so to inform Nginx?

Was the site working with SSL prior to adding it to Cloudflare?
It was working with Cloudflare before I re-installed wordpress.

What are the steps to reproduce the error:

1. install Nginx and conf. its block to wordpress
2.install wordpress
3. open site

Have you tried from another browser and/or incognito mode? YES

Where should I start from?
Proceding to Cloudflare plugin can help it? Or can I have the CA keys to manually inform Nginx?

Can this help? digicert

I’d recommend to pause Cloudflare (bottom right) and check if the site loads fine on HTTPS. If it does not, you need to talk to your host. Once it loads fine on HTTPS, you can unpause Cloudflare.

1 Like

I paused. it doesnt connect.
I am self hosting.
It was ok in the prior installation.
I think I need to know how to get the cetificate creddential/key in order to create an SSL file for Nginx.

It is currently not paused. As I mentioned, keep it paused until it works.

1 Like

is there a way to obtain the keys to the issued cert?

You can get an Origin certificate from https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls/origin

1 Like

Hi Sandro,

On the area mentioned, I see there is no CA.

But there is a *domain certificate:

Did you mean this is where I get the key?

image

No, you need to get a new Origin certificate from there :slight_smile:

1 Like

Ok thanks :slight_smile: a lot.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.