Wrong IP resolved

Hi there,

DNS A is pointing to wrong IP address in BEG data center.
Correct IP address of ws-merge.salestrekker.com is 13.236.191.20 ; BEG datacenter points to 13.73.194.213

0 [email protected] ~> dig ws-merge.salestrekker.com @1.1.1.1

; <<>> DiG 9.11.3-1ubuntu1.8-Ubuntu <<>> ws-merge.salestrekker.com @1.1.1.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 38862
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1452
;; QUESTION SECTION:
;ws-merge.salestrekker.com.     IN      A

;; ANSWER SECTION:
ws-merge.salestrekker.com. 1338 IN      A       13.73.194.213

;; Query time: 17 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Tue Aug 06 11:39:07 CEST 2019
;; MSG SIZE  rcvd: 70

0 [email protected] ~> dig ws-merge.salestrekker.com @8.8.8.8

; <<>> DiG 9.11.3-1ubuntu1.8-Ubuntu <<>> ws-merge.salestrekker.com @8.8.8.8
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 12709
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;ws-merge.salestrekker.com.     IN      A

;; ANSWER SECTION:
ws-merge.salestrekker.com. 299  IN      A       13.236.191.20

;; Query time: 50 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Tue Aug 06 11:39:20 CEST 2019
;; MSG SIZE  rcvd: 70

0 [email protected] ~> dig +short CHAOS TXT id.server @1.1.1.1
“BEG”

But if I check from
[email protected]:~$ dig +short CHAOS TXT id.server @1.1.1.1
“FRA”

All looks OK!

[email protected]:~$ dig ws-merge.salestrekker.com @1.1.1.1

; <<>> DiG 9.11.3-1ubuntu1.8-Ubuntu <<>> ws-merge.salestrekker.com @1.1.1.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 58898
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1452
;; QUESTION SECTION:
;ws-merge.salestrekker.com.     IN      A

;; ANSWER SECTION:
ws-merge.salestrekker.com. 300  IN      A       13.236.191.20

;; Query time: 2 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Tue Aug 06 11:40:19 CEST 2019
;; MSG SIZE  rcvd: 70

You seem to have a wildcard configured which points to that address. The BEG PoP probably still has that value cached. Wait a bit until it is refetched and I’d expect it to work.