WARP stops working

I use Cloudflare for Teams with app (latest version 6.7) on my Samsung Galaxy A41 (Android 11), internet works fine some time, but after some time internet stops working… This happens on all network, on home wifi, on work wifi, on mobile internet… I have disabled battery optimization, memory optimization for app… When internet stopped working I saw “Invalidating resolver address, because of timeout” log in Console logs. I can’t save full logs, when I disable app from home screen, logs deleted automatically. If I don’t disable app, internet not works and I can’t save logs on google drive or send feedback. I have tried send feedback with app many times before, but I did not receive answer… Also, I use with Teams on my PC (Linux) and it works fine… Can someone help me?

1 Like

This could be related to an incident being resolved from below:

Nope :frowning: It not fixed, same problem… Internet worked fine for few hours, but now stopped:


seeing similar issue on a wide variety of android 11 devices (Samsung and oneplus ones)

no replies from feedback about this (sent feedbacks for every device)

only solution here to have internet working is to disable warp

the troubling part is that warp breaks even phone fallbacks (like: use 5G when wifi is not stable or similar) so basically you go fully offline (no notifications inbound, nothing) while thinking the phone to be properly working as everything looks connected.

You realize the whole thing is broken when trying to access an internet web page.

Tried so many things to debug this but so far made no progress at all, did someone find out something that could be causing this kind of behaviour?

Try using network timing in your smartphone. Or check if the timing is proper

How do this?

1 Like

In my smartphone it’s like this. Depending on your smartphone google it or probably it should be in the section were you change device time.

This is my timing settings:

When I connect to “Gateway with WARP”, it connects to “Germany” server, I should change my phone time to Germany’s time?

No I guess. try With any other smartphone and check. Because with my smartphone it was not working too and working in other smartphone. Some one in forum told me to change my timing but before that I had formatted or earsed my smartphone and it did work.

Now I use Galaxy A41 (Android 11), I also tried on Galaxy J3 (Android 10), but not works :frowning: I tried reset settings, factory reset, but not works…

network timing doesn’t change anything in my experiments.

simply when warp+ is enabled after a while (like 1 hour) internet stops working, or, when it does not stop, some notifications simply don’t get received (like slack, or skype) even tho browsing still somewhat works

Yes, this is true :frowning: Cloudflare team should fix this, but no feedback :frowning:

1 Like

it happens on me too
after a few hours i didnt receive any notifications, and i checked on browser to start google it, but even the google cant be opened.
then i tried to turned warp off, and everyhings back to normal
already report it from feedback form and still no reply from cloudflare team

1 Like

I have this problem from beginning the app, I tired to wait years for some feedback or app update, I don’t use cloudflare anymore :frowning:

1 Like

Yeah, unfortunately so far the only solution seems to uninstalling warp…

I’ve also sent multiple reports from each of my own android gears that were having the issue but have not received a single reply and have not seen improvements after multiple months have passed

seems this to be still an issue on a brand new galaxy s22?

The fix is to disable TLS decryption in the zero trust portal, this is not a great fix because you cannot monitor any http or network traffic but it will work.

I hope the team over at Cloudflare fixes this… but I have yet to see any effort for this.

I already tried disable TLS decryption, but I still have issue on latest app version (6.14). This not issue only with zero trust, this happens on WARP/WARP+ too. One way is to disable-enable warp when internet stops working, this way is very uncomfortable. Second way is just uninstall app :frowning:

1 Like

Hi, I experiencing the same and WARP with TEAM it constantly lost internet after serveral minutes/hour. I noticed from boringtun logs, it showing SESSION_EXPIRED(REJECT_AFTER_TIME) when internet lost. I have to keep on disable / enable to get back the internet.

Appreciate if there is a fix for this. Thanks

Following up at this is still happening on latest Cloudflare warp ANDROID app

“Funny” is when the whole internet is broken services that so not rely on dns resolution keeps working

For example

Can be properly loaded (no dns resolution needed here)

You can try checking if the same happens to you.

That means that wireguard is working fine, it is just the dns resolution broken and stopping all notifications and apps internet traffic