Two https calls

Hi, on my web handbolsantquirze.cat/ but also works with www.handbolsantquirze.cat/.

But there are two loading times for the same thing. For instance, in a sequential loading, the first call is to https://www.handbolsantquirze.cat/ and it spends (1935 ms) and after that call to http://handbolsantquirze.cat (3489 ms) (as you can see in the attached file)

Is there any way to unify this in a single call and reduce this gap?

At the Cloudflare level, you can create a page rule with a Forward URL setting to redirect from www.example.com to the naked domain.

Forward URL: www.example.com/*
To: example.com/$1

This way, the redirect will be performed at the edge (a Cloudflare data center), and it will be much faster.

But you should also fix the redirect at your server level. There is no reason why a 301 permanent redirect shouldn’t be cache-able. Your origin is currently returning a cache-control: no-store, no-cache, must-revalidate header, which instructs Cloudflare and users’ browsers not to cache the redirect, even if you have a “cache everything” page rule in place.

Hi,

I already did it, using the Cloudflare way , but now there are three loadings :slightly_frowning_face:

see new screenshot … any idea?

Try adding https:// to the target URL on your Cloudflare page rule, as a way to avoid a double redirect.

Forward URL: www.example.com/*
Target: https://example.com/$1
1 Like

Ok already done , now there are only 2 but the second one still spending many time
Think I already changed the cache control as you said but it still with same result

(see new screenshots - configuration and analysis)

That URL that is taking too long is not being cached by Cloudflare, because by default CF does not cache HTML. So Cloudflare has to fetch it (and wait for it) at the origin every time there’s a request for it.

You’d need to improve the response time of your origin server, or otherwise make make Cloudflare cache your site’s HTML pages.

You can do so with a page rule with a “cache everything” setting, or with a (paid) APO subscription, which combines a WordPress plugin with some Cloudflare settings.

Please search support.cloudflare.com for more on these options.

1 Like

Just to test I created the rule but still doing the same times , maybe I had something wrong?

Can you post a screenshot of your page rule? It doesn’t seem to be working, I get “bypass” for caching.

here there is

Your page is still returning the cache control header with no store, no cache, must revalidate values. To circumvent this, add another setting to the same page rule that has cache everything with Edge Cache TTL = 1 day or so. Then read Cloudflare’s caching documentation and adjust according to your needs.

here there is the result screenshot and the rule


Not Browser Cache TTL, Edge Cache TTL

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.