Switching url to https causes a 404 error

#1

I have received a Universal SSL Certificate. It is active, however when i switch my siteURL from http to https, my site is marked as not secure and every page returns a 404 error. What can be causing this and how can i fix it?

Thanks

0 Likes

#2

Check your server logs. They are usually pretty clear about a 404.

Which SSL setting are you using at Cloudflare? It’s probably Full or Flexible.

Finally, what’s the domain? “Not Secure” is usually caused by Mixed Content.

0 Likes

#3

I have Flexible SSL.
I have disable mixed content through cloudflare and also using a plugin on wordpress.
I think the 404 is being caused by a jquery script that is using http ( ), however i cant seem to find its location.

0 Likes

#5

Your browser’s dev tools may help (F12 in Chrome and Firefox).

1 Like

closed #6

This topic was automatically closed after 30 days. New replies are no longer allowed.

0 Likes