Subdomain has mixed https / http content

Hi,

I have a website www.mysite.com which is running on AWS beanstalk. Https works fine for it but a subdomain isn’t. We are getting mixed content warnings in chrome dev tools.

Things I have tried

We enabled the DNS records in cloudflare to point to the beanstalk environment.
I have set up the self-signed and Cloudflare certificates ( with subdomain coverage).
Http on the subdomain works fine and I can see the Wordpress site fine.

But https is causing me serious problems.

Any ideas what I can try next ?

I suggest you toggle that DNS entry to :grey: DNS Only. Give it five minutes to take effect. Then hit the https version of the website. You’ll get a cert warning in the browser. Take a look at the certificate to make sure it’s the one Cloudflare generated for your site, then click through to accept it. And then see which parts of the website aren’t configured for HTTPS.

You might be able to shortcut this from the Edge Certificates section near where you generated the origin cert. Make sure “Always Use HTTPS” and “Automatic HTTPS Rewrites” are enabled.

1 Like

I don’t think beanstalk is actually enabling https. That seems to be the root of the problem.

Does anyone know how to enable https in AWS beanstalk on a Linux 2 Apache instances ?

I actually spoke with AWS and the code/folders and instructions they provide still won’t make it work. Exhausted and weakening voice here.

They have docs about this. Beyond that, this Community isn’t the best place to get help with configuring AWS.

I actually spoke to them about those docs for encryption on the instance for PHP and Apache and they told me it is for Linux 1 . Outdated doc. But yeah I will chase them up again. Friggin outdated docs drive me Insane - literally

Thanks for your help. I’ll come back and update this thread.

1 Like