SSL Not Activating


#1

Hi guys i need some information.
i’m applied for free SSL and i choose Flexible as the SSL option.
after 3 days it’s not activate on my site.


SSL - Delays Authorizing Certificate
#2

Hi @hannah3745,

It appears that you haven’t yet updated your nameservers to point to Cloudflare. We can’t issue an SSL certificate for a domain until the owner demonstrates control by making the nameserver change.

I would recommend setting all of your DNS records to be gray clouded until the SSL cert is issued (so that traffic isn’t proxied through us w/o a valid cert in place), but fist you’ll need to update the NS records at your registrar.


#3

I updated the DNS. But now I’ve deleted my site from Cloudflare…

After updating the DNS server name. The site was not working properly.

Sometimes the site runs and never runs
it’s bad for site so i removed


#4

hi, i kind of have the same issue.

My ssl is active and my blog is loading perfectly, but I go to any post or URL , the inet browser is showing always NOT SAFE site, like if the ssl is not active. Any idea? Im new with cloudflare . check my blog and let me know please!

reagards


#5

It’s due to:

This page includes a form with a non-secure “action” attribute.

Mixed Content: The page at ‘https://www.leiva.co/’ was loaded over a secure connection, but contains a form that targets an insecure endpoint ‘http://www.leiva.co/search’. This endpoint should be made available over a secure connection.


#6

How can I install SSL to my site


#7

@mybestschoolng, just activate a zone in CloudFlare and you’ll get a free SSL cert for your zone.


#8

Hello sir thank but can I installed full SSL on my site without owning the authority.

And please guide me step by step on how to install the SSL thank


#9

hey,

thanks for replying.

somewhere I read about a code that needs to be added to the form to get it fixed. Do you have any link?


#10

Try using the Cloudflare panel for Crypto and turn on Always Use HTTPS (this may already be on) and Automatic HTTPS Rewrites (this may fix the error).

Otherwise, you’ll have to dig through your template code (or site settings, depending on what your site is running on) to change HTTP URLs to HTTPS.


#11

I did all that, I will try rewrite using page rules since I have blogger and doesn’t have a .htaccess


#12

Follow this blog to Install and activate SSL on your wordpress Website:
https://jonnyjordan.com/blog/how-to-setup-cloudflare-flexible-ssl-for-wordpress/

The Problem here is
When you activate SSL and Set page rule to use HTTPS version always, cloudflare tries to fetch HTTP version and apply its proxy and serve HTTPS version but since your WordPress site is configured to use HTTP version it tries to redirect it to HTTP version and cloudflare again tries to move it to HTTPS. This happen again and again and causes a infinite loop and you gets an error.

The above article will help you to solve the issue.


#13

This thread is puzzling to me. I run a Wordpress site with no cloudflare-related plugins and it’s working fine with SSL. It would help to know why a particular plugin is needed and when not. The URL I’ve found most helpful, so far, is at https://guide.weavertheme.com/free-and-easy-ssl-for-your-wp-site/ My web host is running Let’sEncrypt, and maybe that’s a contributor to why I need no plugins? Any insight will be appreciated, as I’m having no problems and now wondering why.


#14

any fix to this issue? my blog loads the green lock at the beginning and then shows the SSL but no green. All URls has been updated inside the theme. no mixed content issues found.

any idea?


#16

I’m still seeing mixed content errors when I view Developer Tools > Console.


#17

can u screenshot it? pls


#18


#19

ok, I got it. I need to update the post image URLs.


#20

Is it a WordPress site? If so, I’ve gotten the “not fully secure” warning to go away by using a WordPress plugin called Really Simple SSL. I’m not sure that it will fix your problem, but it’s worked for me on multiple sites.


#21

Please recheck the settings