Phpmyadmin is redirecting to https?

I have installed phpmyadmin on ec2 and my instance is behind Cloudflare . when i try to run my xx.xx.xx.xx/phpMyAdmin (where xx… represents my public ip) it gets directed to https and stuck in a redirect loop. any help would be appreciated , thanks in advance

Do you mean public IP = Cloudflare IP or your origin’s real IP ?

Possible reasons for this are

  1. You have Always use HTTPS enabled in SSL/TLS app section
  2. You have HTTP Strict Transport Security (HSTS) enabled in SSL/TLS app section

Do you have http to https redirect on your web server for phpMyAdmin directory? does the origin web server also have HTTPS SSL certificate setup ? If so you might want to remove the http to https redirect from your web server for phpMyAdmin

public ip is aws instance ip

should i disable

Considering you are accessing it via your IP you are bypassing Cloudflare, so you’ll need to check your server configuration.

1 Like

HSTS is not enabled
and i have disabled also “Always use HTTPS”
Let me check and i will come back

could you tell me where to check in AWS LINUX AMI

No familiar with that setup but I’d assume it is somewhere in your webserver configuration.

ok thanks

Maybe it is even phpMyAdmin. Havent used the software for quite a while and they may have added an HTTPS redirect. May have :smile:

I have read somewhere that phpmyadmin uses default https but don’t know how to access it or disable it ?

This topic was automatically closed after 31 days. New replies are no longer allowed.