New CloudFlare's rules on cache-control

cache
#1

We had a big problem on our web service last couple hours!
It looks like CloudFlare have changed the default Cache-Control headers!
It became - cache-control: private, max-age=14400, must-revalidate
So, every “GET” ajax queries to dynamic data started caching!!
This led to the application’s fatal work.
Can anyone confirm changes to the default headers of CloudFlare?

Sincerely.

2 Likes

#2

I thought I was going crazy! This also has happened to our website and is ruining everything!!
I confirmed it was CloudFlare because I changed the Cache Time and saw it updated.

0 Likes

#3

Is your server itself not sending a cache-control header? Or is CF now overwriting your server’s cache-control header value?

0 Likes

#4

I managed to workaround this by setting this to Respect Headers.
This setting hasn’t changed in 5 years (prior to me just changing it).
The issue is that Cloudflare is not supposed to cache HTML content but it is (as seen above).

2 Likes

#5

I have trying to send headers from my server, but CF overwriting them.
I can only influence the cache with - Pragma: no-cache

0 Likes

#6

I have this issue too, my CMS page is now being crazy. New HTML content never updates if I don’t refresh browser several times to see change, I don’t know what to do now and I have to turn off the Orange-Cloud in DNS section.

0 Likes

#7

I can confirm that bug. Will be fixed?

0 Likes

#8

I have tried, it didn’t help. As budgeneration has wrote, you can switсh to “Respect Headers” and setup correct headers on your web server. or add Pragma: no-cache until there is news on the issue.

1 Like

#9

cc @cscharff @cloonan

0 Likes

#10

I confirm we’ve just had the same problem. Seems CF are now inserting cache-control: private, max-age=14400 on all our api requests too.
I’ve just changed the same Browser Cache Expiration to Respect Existing Headers too, as our api was sending cache-control: no-cache. Now it seems to be working again.
How/why did this change? What a massive change!

0 Likes

#11

Respect Existing Headers worked for me, I don’t set any header on my server.

0 Likes

#12

I have the same problem

0 Likes

#13

Changes were applied around 19/03/19 23:00 (GMT)

1 Like

#14

It looks like the issue was fixed.
The default value of “cache-control” was returned back to “no-cache”

2 Likes

closed #15

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes