IP Geolocation


#1

After I turned the IP Geolocation off, I found that my site no longer works so I turn it back on, it still does not work. Any ideas why?


#2

I had to add a page rule to fix it for the time being though the page rule was not necessary before this so would like a better solution.


#3

What page rule? If your site breaks because you turn that feature off we have to assume your site uses that feature, but you would need to debug your site to find where that broke.


#4

Well, by default the IP Geolocation is turned on which was working fine. I turned it off and my site went down. I assumed if I turned it back on, it would work again but it did not. Adding this page rule fixes the issue:
SSL Full
IP Geolocation Header On


#5

I’d be surprised if that had anything to do with that header. How does your site make use of it?

The TLS setting is more likely to have an effect. Maybe your host made some change in that area.


#6

The idea was if I turned the IP Geolocation off it would mask the current IP which the current IP used is based in France so it translated urls with Geo IP such as twitter to french. But it just created a bigger issue and not allowing my site to load. Not even sure if it is even possible to do or if this was the best way to approach.


#7

The header you are referring to has nothing to do with the IP (apart from the fact it is derived from it).

I am not quite sure what the problem was, but considering you seem to have fixed it, it should be fine.


#8

This topic was automatically closed after 14 days. New replies are no longer allowed.