Insecure connection

I activated the ssl certificate and website show secure sign but http has not converted to https

Please help

Are you saying you do not have an HTTPS certificate on your server?

2 Likes

Did you enable the Force HTTPS in your cPanel (if you have it) or use .htaccess to redirect the http to https?

1 Like

Kindly, may I ask, if your website is actually using Cloudflare first?
If so, check that the needed DNS records are :orange: cloud (proxied via Cloudflare).

Furthermore, as already asked, maybe it is due to the URL configuration of your web application (which does not do auto-redirect from HTTP to HTTPS due to being working on HTTP only until now) or depending on the Web server you are using (Apache - htaccess, Nginx - vhost/conf file).

If using Cloudflare, there is an option Always use HTTPS.

Moreover, if interested into redirecting some specific HTTP to HTTPS URLs using Cloudflare, this can be done using Page Rules.

If you need option to fix your mixed content, in Cloudflare there is Automatic HTTPS Rewrites option to help you with that too.

1 Like

I activated free cloudflare service.

And link of my website is still http though service is activated

But still, you didn’t answer his question:

1 Like

i have the certificate but the link is not showing https