Images missing/not loading - wordpress website

Hi Team,

Can someone help me here with my issue on wordpress/woocommerce website?

We are using cloudflare along with WP Fastest Cache plugin on our wordpress website https://www.pcstudio.in/

As per the suggestion from the cache plugin support team we have integrated the cloudflare api with their plugin on wp dashboard.

Post that we are facing couple of issues as below. We are confused as these are post integration effects (as the support team of plugin says no issue with integration) or this is an issue with cache plugin or hosting server or cloudflare.

  1. Images are missing sometime and upon refresh everything loads properly. Sometime during the first load also it loads properly.

  2. We are getting 5xx errors sometimes. Like in a second once we refresh everything loads properly.

  3. It shows data from our old website and shows a refresh button on the top sometime and when we click refresh it takes time & loads properly. May be this is due to always online option

Below is the screenshot for the same.

Can you please help us understand and try fixing these issue as we have many visitors coming onto the website & something happens like this we are scared that we might loose them.

Thanks
Shashikant

Regarding 522 error for each of the resources tried to load up, I assume there is some issue between your hosting provider and Cloudflare, as it could be that Cloudflare is either not allowed to connect to your origin host/server, or some other issue regarding the SSL.

Kindly, may I ask have you checked the suggestions from the below article?:

Are Cloudflare IP addresses allowed to connect to your new host/origin?
Maybe you need to allow Cloudflare IP addresses to connect to your host/origin server:

Cloudflare IP list can be found here:

Has your Website being served over HTTPS before moving to Cloudflare?
Have you had an SSL certificate installed at your host origin/server which covers your domain(s)?
Kindly, check here for a way how to propperly setup an SSL certificate while using Cloudflare:

Moreover, could you check which SSL option have you got selected under SSL tab at Cloudflare dashboard? Is it Flexible, Full SSL or something other?

How about your web server and WordPress website?, does it work on a port which is compatible with Cloudflare as follows in the below article:

Maybe they are both being served over HTTP rather than HTTPS and maybe too much requests are comming from Cloudflare IP addresses, which are not allowed to either connect and/or sent that much of them?
Or, maybe some mixed content in between.

Maybe due to some packet loss to your origin host/server?

Like the one “… website is offline …”, right?

Does anything changes if you Pause Cloudflare for your domain?
Or temporary switch the :orange: cloud DNS records to :grey: cloud?

Try contacting your hosting provider regarding the whitelisting the Cloudflare IP addresses and allowing them to connect to the server.

1 Like

Hi @fritexvz

Thank you for your detailed answers on my problems.

If I am not wrong, as you correctly said, my hosting team is blocking few IPs as they have installed a firewall from their end few days back and any requests coming in 100’s of lots they said they have blocked them.

Let me get in touch with them and get back if I still face any issues.

Also, there is one more issue which started popping up now which is the wp-admin is also showing 522 Error at times while accessing orders, products pages in wordpress.

Is this also related to whitelisting of IPs?

Coming to the SSL we already had an in built SSL with our hosting (VPS) included in the package and the domain was auto configured with the SSL much before we have activated the cloudflare.

Thanks Again
Shashikant

Moreover, could you check which SSL option have you got selected under SSL tab at Cloudflare dashboard? Is it Flexible , Full SSL or something other?

We have set the SSL option to Full SSL.

Hi @fritexvz

We have checked with our hosting team and as per your message above ‘YES’ few IPs were being blocked from the server end.

Now those IPs are whitelisted and I have checked the console now by clearing the browser cache and the missing images issue seems to be fixed as of now.

Let me observer this for a while and get back.

Also, the SSL used is not from the Origin server - my bad as we are using cloudflare’s SSL only.

My hosting team has suggested me to install the same on the server whm panel also for a better output.

Let me know if I need to do that and how can we extract the cloudflare certificate details from the dashboard. If at all we do this can the SSL option be changed to full strict or left as FULL for now.

Thanks
Shashikant

You cannot use the same certificate that Cloudflare uses. Allowing the private key to be extracted is generally a bad idea.

You can use Cloudflare Origin CA Certificates, or use a CA like Let’s Encrypt on your Origin.

@michael

Do you recommend doing anything you suggested right now or just leave it as it?

I mean adding an SSL on the origin?

Yes.

You have said you use SSL Full. This generally means that the certificate on your Origin is not a valid certificate. If you can configure Let’s Encrypt on your Origin that is the option I would take. If you cannot configure LE on your Origin, then Cloudflare Origin CA Certs are a reasonable alternative. Once you have either of those configured, increase the SSL Mode to Full (Strict).

Is this a paid one or we get it along with the free plan included?

Since we are new to this cloudflare, could you help us with some article (if available) on how to extract or generate a new SSL in the free plan and installing it on WHM (hosting panel) manually will be taken care by us (may be with the help of hosting support)

Cloudflare Origin CA Certificates are available on all Cloudflare plans and are available without charge.

Start here to learn how to generate and install an Origin CA Certificate.

@michael

Thank you so much for the help !

By the way the issue which was reported on this topic (images not loading) has been fixed (at least assuming to be) as my hosting team has whitelisted the IPs range from the WHM panel. Post that I haven’t face such issue till now.

Thanks again for your suggestion.

Also, I have been asking on this community couple of times, do you recommend any specific firewall & page rule settings for a wordpress/woocommerce website.

I have configured few of them from my end as per the suggestions from cloudflare & other online tips.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.