Error Content Mixed


#1

Hello,
I realized that my site https://skinon.it/ to load on the various browsers by a warning loading of unsafe scripts. I found out that Bloom font / icons is getting errors due to the HTTPS edition / SSL, as in the screenshot below. The url character does not use HTTPS which is why its giving you that error and why some icons are not displayed.
So this is an error https mixed content like in the figure below. I contacted my host and he recommended installing the Really Simple SSL plugin, but the plugin can not fix the errors. The host told me to check that they are actually viewing the hosting server site, since the domain currently located behind Cloudflare infrastructure should therefore also control cache management.
They tell me that the error is probably due to the Cloudflare services as accessing directly to the server through modification of the hosts file (thus bypassing the services of Cloudflare) the indicated warnings are not displayed.
I did a complete cleanup of the cloudflare cache but I still see the site warning unsafe.
I can ask for explanations or support to solve the problem.
Greetings
Thank you


#2

You should start at the Community Post below but there is also plugins that will automate this process.


#3

I checked everything (except for point 5 I do not understand), but the problem does not seem to be resolved. Other suggestions. Thank you


#4

Sorry for not mentioning this earlier (missed my morning coffee) but have you set Cloudflare to Automatic HTTPS Rewrites?


#5

Yes, ibut it does not solve.


#6

Seems like you’ve covered everything I can think of. Perhaps someone else here may have a suggestion.


#7

Ok,Thanks


#8

Hi @skinon.pd, looks like you have a redirect on your server, if I force www.skinon.pd I briefly see a secure page and then redirect to skinon.pd. SSL is active and the certificate is issued and in place, but the mixed content issues prevent the page from loading securely. Auto https rewrites won’t affect scripts and you’ll need to manually edit those. Once you have the mixed content issue resolved (shield on right side of address bar will go away), you’ll need to dig into your ssl settings and whatever redirects are happening on your origin.


#9

Thanks for the reply. But in practice.
How do I manually edit “for example”:
http://skinon.it/wp-content/plugins/bloom/css/fonts/ET-Bloom.woff?gd6mr8
Which section of the cpanel should I go to?
Just enter a redirect in functions.php?
In which file can I use ‘search and replace’?
Could you give me a specific indication on how to do it or a link to a tutorial?
Thank you


#10

Hi, the tip @Withheld shared has links to the howtos. If you use chrome, to see the errors select the 3 dots in upper right, click more tools, slide to developer tools, and click console view. That will expose the errors needing correction. You’ll need to edit your site to change those calls from http to https or even better to a relative call that will work with http or https. The line you mentioned would change to https://skinon.it/wp-content/plugins/bloom/css/fonts/ET-Bloom.woff?gd6mr8 or if relative to //skinon.it/wp-content/plugins/bloom/css/fonts/ET-Bloom.woff?gd6mr8


#11

thanks, but how do I change this line materially, perhaps on the database? The line I mentioned is not a page or an image to which I can directly change the URL.


#12

Understood, thank you. What tool do you use to create your site?


#13

I solved by disabling the plugin plugin of extras, thanks too for your availability


closed #14

This topic was automatically closed after 30 days. New replies are no longer allowed.