Error 400 on Auth Code

#1

Having the same issues with my .ninja domain.

Looks like cloudflare is throwing a 400 error when checking my auth code.

  1. Request URL:

https://dash.cloudflare.com/api/v4/accounts/~blurredabit~/registrar/domains/mihaiturcu.ninja/check_auth

  1. Request Method:

POST

  1. Status Code:

400

Response:
{“result”:null,“success”:false,“errors”:[{“code”:10000,“message”:{“message”:“Invalid auth code”}}],“messages”:[{“message”:“Invalid auth code”}]}
Response headers:

  1. cache-control:

no-cache

  1. cf-ray:

4c1ea887ccf6ac96-OTP

  1. content-type:

application/json; charset=utf-8

  1. date:

Wed, 03 Apr 2019 23:00:22 GMT

  1. expect-ct:

max-age=604800, report-uri=“https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct

  1. served-in-seconds:

0.101

  1. server:

cloudflare

  1. status:

400 Bad Request

  1. status:

400

  1. strict-transport-security:

max-age=15780000; includeSubDomains

  1. vary:

Accept-Encoding

  1. x-request-id:

dcc7939481c6d7ad7cf595d71920675b

  1. x-ua-compatible:

IE=Edge,chrome=1

Doing a GET request against that route returns the following (I expect it to not matter since it’s probably a POST intended route)

{
“success”: false,
“errors”: [
{
“code”: 9300,
“message”: “User session has expired. Please log in again”
}
],
“messages”: ,
“result”: null
}

Maybe because my auth code contains $ and ( chars? No idea.
Saw some names in other threads so I’m gonna ping people @SamRhea .

0 Likes

Auth code failure from namecheap
#2

Hi @mihai.turcu0, sorry for the issue. I’ve not seen this for a couple of months. If you’re doing a copy/paste, check there are no leading/trailing spaces and verify you’re using the correct code. In January, folks that saw this issue with .ninja and Namecheap domains were successful in retrying the transfer. To do that you’d need to request a new code from your current registrar. Please let us know how it works out.

0 Likes

#3

Absolutely sure I’m copy/pasting the code correctly. I even tried typing it once.
I’m reaching out to support to generate a new transfer code.

Later edit: I’ve reached out to namecheap support and asked them to regenerate the transfer code. I’ve informed them of my intention of transfering to Cloudflare. After regenerating the transfer code, it worked :slight_smile:

Thanks.

0 Likes