I’ve just setup my domain in Cloudflare. My previous experience with Cloudflare in enabling HTTPS was very quick but this time some error happened. Setup the site in Cloudflare 1 hour ago and has enabled the HTTPS and suddenly getting the “ERR_SSL_VERSION_OR_CIPHER_MISMATCH” error on my site. SIte was working fine until I’ve enabled the HTTPS.
Its a free version, flexible ssl.
Can somebody please suggest a solution?

Thanks in advance.

1 Like

Same here, nothing helps.

You SSL certificate probably isn’t active yet. Check the Crypto section on your Cloudflare account. The top of that page should have the SSL status and settings.

Thanks for the reply. Now its been corrected, I think it needs to get resolved and its just a matter of time.

1 Like

I still got the same error.

Same here. Dashboard shows active certificate but I get an error for all HTTPS requests. It’s been 36 hours since I enabled SSH

I am now having the same issue. I have an active certificate and had SSL working on my site for a few months. Recently I noticed the site wasn’t secure anymore. Now I can’t even access the site. I have opened a ticket as when I run a SSLshopper scan it says I don’t have an SSL certificate at all.

Same here activated 3 domains to try before offer Cloudflare our hosting customers. 2 domains works fine but third have no Universal SSL cert for days. We are on Plesk with Plesk Plus plan. Support contacted (1512171) but no help although I exactly described what is the issue. Really disappointed with Cloudflare. Looking posts here “ERR SSL VERSION OR CIPHER MISMATCH” and missing or not issued Universal SSL is big issue but not fixed generally and the customers need to pray here in forum until somebody react and fix it. Very bad and after this experience we’ll not offer Cloudflare to our customers.

I face this problem before. Just disable your flexible SSL below SSL/TLS app option. Wait a cople minutes, then reactivate new flexible SSL request.

This topic was automatically closed after 14 days. New replies are no longer allowed.