Change http to https

ssl

#1

Since I change my site from http to https in WordPress manually they say “This page isn’t working”.

My domain name is from GoDaddy as my first hosting.

SSL in crypto is flexible I try the full and full (strict) they don’t work.

Always use HTTPS in ON.


#2

Hi @charocshop, if you want to share the domain, the community may be able to assist. Where are you seeing that error message “This page isn’t working”? I took a guess to troubleshoot and (if I guessed correctly), noticed that ssl is active and a Cloudflare certificate is in place, but a lot of mixed content issues. You could try turning on Automatic HTTPS Rewrites (also under the Crypto tab) to address mixed content. There is a great mixed content article here, https://support.cloudflare.com/hc/en-us/articles/200170476-How-do-I-fix-the-SSL-Mixed-Content-Error-Message- it even has has a wordpress section!


#3

Thank you sir for replying.
The domain is Charoc.com
I saw it when I want to open my site in the mean page.
I don’t have the paid certificate.
I tried to turn in on sir.
do I need to confirm the “Disable Universal SSL” ?


#4

Hi @charocshop. Thank you for the details, and now I also see the error. I’d leave Universal SSL as is for now as I went to https://charoc.com/blog/ and can see ssl is active and the certificate is in place. But, there are a lot of mixed content errors on the site that are visible using Google Chrome developer tools console view. Couple of suggestions: 1. I’d fix the mixed content issues (link earlier in this thread) and 2, research Page Rules for directing traffic as you’d like. Here is a good Page Rules introduction: https://blog.cloudflare.com/introducing-pagerules-url-forwarding/. Please post back and let us know how you progress.


#5

Hello sir
i didn’t lnow how to do these steps.
i didn’t find a toturial on youtube too sir.


#6

Hello sir can i just have back up ??


#7

Hi @charocshop, sorry, not following you on back up…

To make the changes, after you login, go to the Crypto tab and turn on Automatic HTTPS rewrites and Always use HTTPS. These articles describe each:

  1. Automatic HTTPS rewrites to address mixed content issues, article here, https://support.cloudflare.com/hc/en-us/articles/200170476-How-do-I-fix-the-SSL-Mixed-Content-Error-Message-
  2. Aways use HTTPS, to force https v http, https://support.cloudflare.com/hc/en-us/articles/200170536-How-do-I-redirect-all-visitors-to-HTTPS-SSL-

Beyond those two changes, you may want to do a search for page rules to understand how you can direct folks to www.charoc.com (or as you like) instead of charoc.com, good link above and intro page here, https://www.cloudflare.com/features-page-rules/


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.