Caching does not work


#1

Hi all,
i got a multilanguge wordpress with 10 different domains. Currently i have SuperCache enabeld, but i want to switch to Cloudflare. For the test i set Cloudflare up with the domain: https://www.bachelorprint.fr/
In Wordpress i didn’t do any changes. In Cloudflare i have a page rule for https://www.bachelorprint.fr/* to cache everything.

The Problem: Any optimization from Cloudflare do not seem to be working. There is also no difference for example in Google PageSpeed Insights. Furthermore i thought, when i enable the full cache, there won’t be anymore requests to my server. However i can see, when i delete all the Supercache files on my server, the sitespeed is incredibly slow, which seems to confirm that Cloudflare isn’t speeding up anything.

Do you have any idea, whats might be wrong here?

Regards,
Oliver


#3

Some of these resources are being loaded from bachelorprint.de which do not seem to be running through CloudFlare.


#4

thanks for your answers!
@jules: Is the “Request URL:” the URL where the file has been loaded from? If thats the case, it seems like that almost everything is being loaded from bachelorprint.fr & bachelorprint.de and only some files from cloudflare.
Also all the images have bachelorprint.fr as Request URL.

attached you will find the rule settings, if that helps:


#5

Something in your wordpress site is loading resources from bachelorprint.de.

The way this site was built, and how it’s loading the resources, is what is making it take so long to load. Lots of scripting going on… it’s like almost 10 seconds of lazy-loading scripts.

If I turn off javascript, your page loads within two seconds easily.


#6

So there is no way that Cloudflare can boost it up?


#7

No, because it’s not CloudFlare that is controlling the loading of all the scripts. It the browser being told to do so by ajax. Cloudflare is returning the requests very quickly. It’s the ajax code and browser that is slow in making the requests.

You can see that most of them return between 40ms and 200ms. That’s fast enough.
But you have over 170 of them. And since they are scripts that are not loaded asynchronously, they stop the browser with each one loaded.
image


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.