301 redirect issue https

hi,
adding page rules on

example.com/*
Forwarding URL (Status Code: 301 - Permanent Redirect,
https://www.example.com/$1

but still, http://www.example.com page does not redirect to HTTPS

The page rule pattern example.com/* does not capture www.example.com

A simple way to do this without creating redirect loops would be to enable the “Always Use HTTPS” setting:

https://developers.cloudflare.com/ssl/edge-certificates/additional-options/always-use-https

1 Like

Thank you for your reply
if creating both rules any conflict issue on site

example.com/*
Forwarding URL (Status Code: 301 - Permanent Redirect,
https://www.example.com/$1

and

http://www.example.com/*
Always Use HTTPS

Those two rules will not interfere with each other.

2 Likes

Thank you for helping me and clearing all my doubts.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.