SSL doesnt work

Didnt work, even a new created site with


doesnt work.

If you manually enter , does it load with the Cloudflare certificate? If so, you are probably not forcing HTTPS, enable ‘Always use HTTPS’ in the SSL/TLS app of your Cloudflare dashboard.

Thanks! That worked! ;:smiley:

Your Most Welcome ! :grin:

Another question: my site doesnt show buttons and stuff when i access to it via Cloudflare. only when i use the ip it works

Ok . What’s the domain i have a look at my side and tell you .

can you share a screenshot of your buttons ? and other text present on your website

I see no issue the website is fine .

Just use

real website is this.

any idea?

Now it’s working fine for me please confirm from your end


You dont understand. It works with the IP Adress but it doesnt with the Domain. For me, it doesnt work


Thank you for asking.

May I ask if you have added Cloudflare IP’s to Nextcloud configuration file? :thinking:

Re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

Furthermore, before moving to Cloudflare, was your Website working over HTTPS connection?

If you already have Let’s Encrypt on the server, you are good.
Make sure to select Full (Strict) SSL by navigating to the SSL/TLS tab of Cloudflare dashboard for your domain name:

Otherwise, may I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

In terms of a Nextcloud, you could have issues if you are on a Free plan (even Business) and going to upload files larger than 100MB. Per default, you are allowed to upload 100MB for proxied :orange: hostname (DNS record) in a single request.

Cloudflare limits the upload size (HTTP POST request size) per plan type:

  • 100MB Free and Pro
  • 200MB Business
  • 500MB Enterprise by default. Contact Customer Support to request a limit increase.

Source article:

Otherwise, if you are on Business or Enterprise plan, you can increase this (Business up to 200MB and Enterprise 500MB or larger upon request) and upload larger files.

I’d suggest you to either split it in smaller chunks, or continue using unproxied :grey: (DNS-only) hostname (DNS record) when you are uploading such large files. After you finish, switch back to :orange:.

Furthermore, try disabling / removing the Content Security Policy (CSP) for which I can see it is causing some issues and prevent them from loading your website resources.

Try disabling Rocket Loader at Cloudflare.

I’d suggest you to test and temporary enable the “Pause Cloudflare” and check if it works by accessing directly via your domain name by:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.
  4. If all good, un-pause Cloudflare

My config only has my domain and localhost ip.

My site is working via IP, but it doesnt load completely with the Domain ( &

My SSL Option is Flexible

Right, thank you for feedback information.

Kindly, do the steps as suggested and instructed from my post.

In terms of below SSL option:

That’s the another issue which is why Flexible SSL is really not recommended to use as there could be multiple issues caused by using it as follows at the below article like Mixed Content or Redirect Loops, etc.:

I disabled Rocket Loader. Works now!! Thanks

1 Like

I can confirm.
Now when I access your Nextcloud via domain, I can see login form as you saw it only while accessing directly via IP :wink:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.