Zola 0.14.1 broken on Cloudflare Pages

Hey there!

I’m using the static site generator Zola to build my website. Cloudflare Pages supports building Zola pages and specifying a Zola Version via an environment variable called ZOLA_VERSION. Unfortunately with the latest version 0.14.1 it doesn’t work, so I have to use 0.14.0 instead.

This is the error shown in the build logs:

zola: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by zola)
zola: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by zola)
zola: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.26' not found (required by zola)
error Command failed with exit code 1

Could somebody look into this, so that Cloudflare users can use the latest version of Zola?

Cheers,
Max

2 posts were merged into an existing topic: Cloudflare Pages - Zola build fails (GLIBCXX_3.4.26’ not found)