ZeroTrust + WARP network issue

Hello,

i am using ZeroTrust + Warp. both of my devices (Laptop,Mobile) are connected to same Gateway but doesn’t seem to be in same network.

Currently i have hotspot enabled on my mobile and i am connected to hotstpot through my laptop.

Issue is that my KDE connect app requires both of my devices to be in same network to operate, but unfortunately after switching to warp i am not able to discover my devices inside the app.

any ideas on how to resolve this ?

Connecting 2 devices doesn’t immediately enable them to be seen by other devices on the Gateway, hence zero trust. To achieve the functionality you’re looking for, you’ll need to setup private network using Cloudflare Tunnel, however that will only enable your phone to see the laptop, and not vice versa (assuming that the laptop cannot currently see the phone on the hotspot). You may need your own VPN solution in this scenario.
https://developers.cloudflare.com/cloudflare-one/tutorials/warp-to-tunnel/

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.