Zero Trust tunnel supporting FTP?

I have a local NAS server and using the Tunnel to access the external internet.
I want to know if there is support for using FTP with cloudflared tunnel.

I tried looking in the documentation but couldn’t find it.

The ftp is working on the local network, without problems, using the local ip.
I want to access using the domain I configured in the tunnel.

You would have to have a cloudflared tunnel setup on your client as well as the server, but it is possible.

I’ve done the configuration on the server, but when I try to connect it won’t.
Has anyone done it or know how to do it?

Client side requires downloading cloudflared software and run commands in order to establish a connection with your FTP server. Did you do that?

Anyway, an example of client-side command:
cloudflared access tcp --hostname --url localhost:21

1 Like

Even using this command or doing the tcp configuration through the dashboard, it still does not connect

WRN Register tunnel error from server side error=“you are using Cloudflare Tunnel in a (legacy) way that is no longer supported.Migrate to Named Tunnels to continue exposing your private origin through Cloudflare’s Network.You can follow this guide: as an example.Alternatively, you can go to Create and rely on the User Interface instead.” connIndex=0 ip=
2022-11-26T22:09:08Z INF Tunnel server stopped

I created the tunnel through the dashboard, it is already a named tunnel.
This error should not occur.
This link talks about an additional configuration. I’ll try it and then come back to say if it worked.

What was the command that you executed in the FTP server while installing the cloudflared?

sudo cloudflared tunnel --hostname --url tcp://localhost:21

When using this command, the error that it gives warns that I am using a legacy mode

Then I tried using the:

cloudflared tunnel create
url: http://localhost:8000tunnel: credentials-file: /root/.cloudflared/.json
cloudflared tunnel route dns
cloudflared tunnel run

Tunnel connects normally with no errors, but does not respond to ftp.
I think I made a mistake in the config.yml settings
I changed https to tcp, it still didn’t work.

Seems like you missed the step where you need to run the command provided by the Zero Trust dashboard to install cloudflared as a service.

You said you created the tunnel through the dashboard, then you should see this once you created the tunnel.

I already have tunnels working on the machine, I already did this step.
What doesn’t work is when I try to create a tunnel to use ftp.