Zero trust tunnel public hostname disable force https proxy redirect

Hello

I have a centos 8 server with a lot of docker-compose containers and subdomains to each of them using a reverse proxy with nginx.

I’m trying to use zero trust tunnel to map the subdomains (parked on cloudflare) to the private ip address of the cointeinrs, this part works fine but when we access the subdomain url it always forces/redirects all the traffic to httpS like the “proxy” option on cloudflare DNS managment.

Now, the thing is that our application is not ready to always use httpS enabled since some assets are loaded over plain http protocol getting “cross load content errors”. that breaks our bussines logic.

So for now, we need to load all subdomains unther the tunnel to load over regular http instead of httpS always.

How can I disable the force httpS redirect on zero trust tunnel panel?

Thanks

I’ve met with the same problem. Does tunnel work with http at all? I tried this

Disabled Universal SSL at all, switched off proxy to https in dns records, but all this not help. I can’t open my page at all, if I open with http.