Zero Trust to Windows Server

Hi,

Problem:- Zero Trust Tunnel to Windows Server only talk to local server via IP and not DNS name.

Recently created a zero trust tunnel to a windows server, problem is we can only talk to the server via it’s internal IP and not via the internal DNS name?

Is there a tick box or something I’ve missed?

Testing - Currently using a Windows Laptop via separate WIFI network, using Cloudflare Windows 1.1.1.1 app. User is logged into the app as allowed email address to talk to the tunnel / server. As mentioned works fine using server IP but not DNS.

Thank you.

Steve.

This app is just for DNS, so it could be overriding the DNS servers on the computer. You might want to look at the warp app.

So you have a DNS resolution issue. When you do an nslookup or dig for the server FQDN does it resolve to the same IP address?

Hi,

@Cyb3r-Jak3 have the WARP Client installed, this used to work fine until the lady got a new laptop. Version is latest 2022.4.115.0

@cscharff nslookup times out when talking to 1.1.1.1 but responds afterwards with the server IP when using FQDN.

Managed to fix it.

As the client has Firewall Proxy / TLS and AV enabled, I had forgotten the certificate.

Installed the desired Cloudflare certificate as trusted root certification authorities, rebooted for good measure and everything works as it should.

Thanks, everyone.

Steve.

3 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.