Zero Trust Private Network Not Working

I’ve set up Zero Trust by:

  1. Creating a team
  2. Creating a tunnel (Docker)
  3. Removing my subnet from excluded IPs in Split Tunnel
  4. Adding my network to Private Networks

What did I miss? My intention is to replace WireGuard with Zero Trust to access my entire network.

  1. Configure device enrollment permissions to see who can enroll to WARP
  2. Ask users to enroll to WARP

Check that Proxy is enabled (Settings->Network->Firewall->Proxy). It may take a few hours to kick in once activated.

Yes! I did that too. Sorry, I forgot to mention those critical steps.

I didn’t see that in the documentation (or any guides on how to do this). Are you sure that’s necessary? I’m just looking to have normal VPN functionality through the tunnel (ping device, etc).

Also, is the Proxy setting limited to only TPC/UPD traffic? Pings won’t work?

Well, here you are:

Remember it may take a while to start working after you activate it.

Thank you! I’ll report back if I eventually get this to work.

I faced this problem. Mr @erictung sent me your link.
I finally did it. Please have a look on this file, I set and noted here.
How to access NAS via Private network using Cloudflare Zero Trust

Thank you, but the link doesn’t seem to be working for me. Can you post the url?

Cannot @a1122 . How can I send you this file? Have you got email?

How about pastebin?

Here’s an updated version of my settings (which aren’t working).

What is your mode here? Show it so we can see

Mode? Where can I get that info?

You set at 1 or 2?

Yep! is your private network, at home, right?
The subnet mask /24 is right or not. To me, I use, the system use default /32. I have to change it to /24, and it works.

Yep, that’s correct. That’s my subnet at home.