Zero Trust "free" purchase fails

Like many others here, I am also trying to add an application in Zero Trust, and it redirects to the purchase plan wizard, which eventually fails to complete the purchase. The purchase button is literally greyed out at the very end.

Could someone here escalate?

I have created a billing ticket: #3119419

Thanks for your help everyone!

2 Likes

FWIW, I’ve tried re-adding my credit card info; verified I am super-admin; and also tried incognito mode.

I’ve the same problem. In Edge, console shows this error:
POST …dash.cloudflare.com/api/v4/accounts/…/subscriptions 402 (Payment Required)

I also tried Edge in mode InPrivate and Firefox, with the same results.

My ticket: #3119876

I have this same issue. I also submitted a ticket (3119721). I’m hoping this gets resolved soon.

Our internal team has deployed a fix for this. You should be able to enable the ZeroTrust Free plan now.

Thanks, it fixed the problem and I am able to add applications now.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.