Zero Trust Cloudflare Tunneling TCP Protocol doesn't work

With the new protocol changes on ISP, I’m unable to port forward from home network. so i decided to use Cloudflare tunneling.

I’ve been trying to tunnel local port 25565 for my Minecraft server. I tried to tunnel TCP port 25565 but it doesn’t seem to work.

I tested http protocol just to confirm if my setups and configs are correct. The Http protocol work fine. I tried SSH as well, neither does this work.

Here is my config file.

For TCP, you need to have cloudflared on the client as well.
I wrote a blog post about this


Thank you, that works well.
is it the same for SSH protocol?

Yes, any protocol other than HTTP requires cloudflared on the client.


A quick note for SSH and VNC is that Cloudflare offers browser rendered version which means you won’t need cloudflared on the client.

1 Like

Are there any options for a client that will not allow cloudflared to be installed such as an NVR? Trying to access an NVR on TCP port 9000 and it won’t work. But I can get https to work just fine. But the https webview is not mobile friendly.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.