Zero Trust Access Policy Not Working "Access Denied"

Hello people, I’ve been using Cloudflare access from a very long time, way before it was named “Zero trust” and got its own dashboard.

Before today I never needed to change the configuration of my applications and give access to new people but when I tried adding new policies today, none of them seemed to be working, only the old users have access to the applications, not able to give access to new users.

I tried adding policy via user group to allow certain email like [email protected] and even tried emails ending with but when tried to test the policy it showed “Access Denied” saying that no user exit. Apart from that I also tried to test it actually by accessing the application and even there the access was denied.

Even tried adding it without user group and directly to application policy but it was still not working.

Can someone please help me how can this be sorted? Is using WRAP compulsory for Access to work? because for old users I never used WRAP and it still works fine.

What command are you using to access the application? What protocol? What is the error you get?

Hey, thanks for replying, its working now. It was taking some time for Cloudflare to send the OTP emails. Received all of them together later.

Have been trying to work with this for atleast 3 hours :confused:


Sounds like an availability issue (something on Cloudflares side not yours)

Ah yes there was an outage today: Cloudflare Status - Cloudflare Access Availability Issues

Cloudflare is investigating delays in transactional emails, including the one-time pin emails used in Cloudflare Access.

Looks resolved