Zaraz - Consent Window - Bug with Scrolling, Consent buttons not visible Iphone

I’ve encountered a reproducible issue with Cloudflare’s Zaraz on ALL iPhone devices where the consent screen fails to display content after scrolling.

This issue makes sites inaccessible, as it also lacks an option to exit the consent screen.

The problem appears to be widespread across different websites that implement Cloudflare’s consent management.

Steps to Reproduce:

  1. Visit a website using Cloudflare consent management, such as www.simes.me, on an iPhone 14 or iPhone 15.
  2. Trigger the consent modal, which includes multiple consent criteria requiring scrolling to view in its entirety.
  3. Attempt to scroll down on the consent modal. Notice that while the screen scrolls, it fails to display any content, showing only a blank (white) area.
  4. Observe that there is no option to dismiss or exit the consent modal, leaving the website effectively inaccessible.

Expected Result:

The consent screen should properly display all content as the user scrolls down, and there should be a clear and functional option to close the consent modal.

Actual Result:

When scrolling through the consent modal, the content disappears and only a blank white screen is shown. Additionally, users cannot exit this screen, preventing access to the website.

Devices Tested:

  • iPhone 14
  • iPhone 15

Example Sites Affected :

https://www.infogt2000.com /
https://www.complex-it.de/

Additional Information:

This issue has been consistently reproducible across multiple websites using the iPhone 14 and iPhone 15, suggesting a broader problem with the Cloudflare Zaraz configuration or compatibility with iOS browsers.

Attached is a screenshot illustrating the issue as observed during testing.

Since no one is answering on my request and post I will temporary turn off Zaraz Consent until this issue is solved by Cloudflare or if someone from community is solved. I will also try to send direct official support request to them.

The team is looking into this. We will update here

Our team tested this with iPhone 14 iOS 17.4.1 and cannot reproduce the issue.

Dear yoav,

I you are testing simes.me example site you cannot see that consent because i turned it off since it causing issues for site visitors. I did this because there were no answers for a long time and i was under pressure to fix problem for my site.

As said problem is wide spread and is affecting every Iphone under conditions I posted.

I also posted official Cloudflare support ticket directly to your Support Team.
https://support.cloudflare.com/hc/en-us/requests/3260188

Ticket id is #3260188

We realized you disabled on simes.me, because you already wrote that you did. However we tested on other websites with a long consent modal and we were able to scroll down to the buttons and click them just fine.

Can you please provide list of examples of sites you tested against. I would like to test that also on my side.