Your connection isn't private error when Cloudflare is active

Answer these questions to help the Community help you with Security questions.

What is the domain name? theisifiso . com
Have you searched for an answer? Yes

When you tested your domain using the [Cloudflare Diagnostic Center] what were the results?

Describe the issue you are having:
I am getting “Your connection isn’t private” when Cloudflare is active on my site. This has happened suddenly and can’t find a way to fix this issue.

What error message or number are you receiving?

Your connection isn’t private

Attackers might be trying to steal your information from theisifiso . com (for example, passwords, messages or credit cards).

NET::ERR_CERT_DATE_INVALID

RefreshHide advanced

What steps have you taken to resolve the issue?

  1. I have deleted the SSL certificates on my host server
  2. I have tried changing the SSL encryption mode several times with no success

Was the site working with SSL prior to adding it to Cloudflare?
Yes and it was working with Cloudflare too. But has stopped working suddenly.

What are the steps to reproduce the error:

  1. Unpause Cloudflare on the site and the error is shown.

Have you tried from another browser and/or incognito mode? Yes

Please attach a screenshot of the error:

Your site is currently using a wildcard certficate for your host’s domain: *.greengeeks.net.

Do you currently have a valid certificate for your domain that covers both the apex and the www name?

If you do, you should install that certificate on your origin server. Otherwise you should acquire and deploy such a certificate. You can use a certificate from a commercial certificate authority. Automated free certificates from the Let’s Encrypt CA often are a good option. If you expect to route all of your traffic through the Cloudflare proxy :orange:, using a Cloudflare Origin CA certificate can be an attractive choice.

1 Like

I have installed a Let’s encrypt certificate on my host. But if I install the certificate and unpause Cloudflare the error shows up again.

Everything works fine only if Cloudflare isn’t enabled. What do I do next please?

That Let’s Encrypt certificate is expired. They need to be replaced every 90 days. Since your DNS is currently returning Cloudflare IPs, I presume that you are :orange: proxied and that Certificate is your edge certificate from Cloudflare. You might try to disable Universal SSL and re-enable it. You can ignore the part in the guide about uploading a certificate to Cloudflare since you will be turning Universal SSL on again.

What website are you using please to check this? I have checked using SSLShopper and many other sites and they all show SSL has been installed correctly. I am new to all this, so forgive me if I am wrong.

I used your website. That was the certificate sent by your site at the time I posted the image.

1 Like

Thank you. Does it still show as expired?

My hosting company’s support team said they installed the certificate on 09-November and it has not expired. But if I unpause Cloudflare, my website fails. Everything seems to point to issues with Cloudflare settings, but I am not sure what I need to change.

These are my settings:
Edge certificates:

Thank you

The certificate on your origin server expires 2023-01-23. It should automatically renew about 30 days in advance. That gives you time to work with your host on troubleshooting the automated renewal before the certificate expires, if anything goes wrong.

At the bottom of the screen in the image you shared, you will want to enable Universal SSL. You should then be able to switch back to :orange: using the proxy.

Hi,

I have deleted the host certificate and then enabled Universal SSL (but not with HSTS enabled) and it didn’t work. As soon as I unpause Cloudflare, the privacy error pops up again. The hosting support team installed the certificate again as my website was down for 3/4 days as I couldn’t figure out the right settings to get Cloudflare to work properly.

The question is how was this setup working before my certificate renewal? Why does Cloudflare have an issue with the renewal or is it something else?

I have deleted my website from Cloudflare dashboard and recreated it, Still no change.

My hosting support clearly tell me that this is a Cloudflare issue and they can’t resolve it at their end.

Is there a way to run a test to see what the issue is? Or how do I get support team to investigate?

Thanks
Kavitha

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.