Your connection is not private over temperary nameserver change

I have an issue with Cloudflare SSL not working.

I had an issue on my server over another problem and Godaddy wanted to make sure it was not Cloudflare related. So they moved my domain back to there service DNS and tested what my issue was.

After that, I pointed my domain back on Cloudflare. All the DNS records are still the same and the firewall works as normal on here. However, when I go to my website I see this


It says it’s Full so why is it not working.

Certificate Information is not trusted.

I’m now wishing Godaddy did not move the domain to their site just for a test. How can I fix this?
BTW I use the free SSL. Not the paid one.

NM Problem Solved.
For educational perpuses on how I fixed it.

  1. I clicked on SSL/TLS
  2. Overview Tab
  3. Checked "Off (Not secure) (Turns off Always Use HTTPS)
  4. Checked Full
  5. Clicked “Edge Certificates” Tab
  6. Always Use HTTPS Checked to On

Problem solved. It’s Valid Again!

This topic was automatically closed after 30 days. New replies are no longer allowed.