Your connection is not private..... Help

#1

Hi guys, I’m having an issue with my website and pulling my hair out trying to resolve it. Before I go fully into changing the DNS I wondered if some of you wouldn’t mind spending a minute to check how the website loads for you: https://www.badgesandstickers.co.uk
Friends I have asked say the page loads ok but I’m getting the privacy error on multiple devices here.
Any help is massively appreciated as I’m losing sleep and business with this.

0 Likes

#2

It looks like you have a dedicated certificate?

www.badgesandstickers.co.uk works fine, but badgesandstickers.co.uk isn’t covered by the certificate, hence the privacy error.

Edit:
What is your Cloudflare setup? The nameservers aren’t set to CF and I can’t see any evidence of avpartner setup, but you have a CF certificate?

3 Likes

#3

Thanks for checking. I stupidly purchased a certificate from Moonfruit who have been useless in helping out with my problem. I’ve since found CF and wondered if it’s worth switching over (I haven’t done anything yet) or will I completely brick my website?

This is the screen I see when I try and view the www.badgesandstickers.co.uk
Badgesandstickers.co.uk loads fine as you say it doesn’t have the certificate. Obviously I’d like it ke to have the whole website secure but it’s pretty confusing stuff for me!

0 Likes

#4

Yes, Cloudflare should work fine with your site. You do also need a certificate on the server to make your site fully secure. You should probably redirect non www to www and set your SSL mode in Cloudflare to Full (strict).

1 Like

#5

For me it is actually the opposite. www loads, the naked domain does not and panics with a 526. That would indicate the server has some issue with its HTTPS configuration. I’d contact the host about it.

1 Like

#6

Thanks so much for your help guys. I think i’ve now made it so badgesandstickers.co.uk redirects to the www version (maybe why you were getting an error Sandro as you checked while i was changing it?). I’ve setup the nameservers as per CF has told me to.
My site now finally loads on my PC. Only a couple of pages are secure though and not really sure where to go from here.
The certificate on the server Domjh, is that the ‘Origin Certificate’ in the ‘Crypto’ tab which you can create on CF? If so, i’ve done that but Moonfruit don’t seem to have an option to upload it to anywhere

0 Likes

#7

Yes, this now works for me :slightly_smiling_face:

It can be any valid certificate, so one from your provider or a free origin certificate from Cloudflare. In my opinion, your host really should allow you to upload one at no extra cost, but some will insist on charging for it.

1 Like

#8

Thanks a lot for your help guys. I’m working through making every page secure as the ‘add to cart’ buttons were http. Just got a couple more pages to change.
Is there anything you would recommend me to do, like settings for CF, or does it all look ok?

1 Like

#9

Looks fine to me, as long as your SSL mode is set to Full (strict), you should be good to go :slightly_smiling_face:

1 Like

#10

Yep I’ve done that thanks.
I am still getting this message on my phone but I’m hoping it’ll sort itself out in a day or two.

1 Like

#11

Just noticed a 526 invalid SSL on badgesandstickers.co.uk, www works as expected.

Can you try adding a page rule in Cloudflare for badgesandstickers.co.uk/* with setting ‘Forwarding URL’ and tell it to forward to https://www.badgesandstickers.co.uk/$1 and see if that works. The redirect from your server doesn’t work any more as the CF error kicks in first.

1 Like

#12

Thanks for that! I’ve just set that up.
I originally made the site forward to www but then i couldn’t use the Moonfruit editor so they had to change it to no preference. Hopefully this forwarding works.

1 Like

#13

I am redirected now to the secure www version :+1:

1 Like

#14

Great stuff, when i type in badgesandstickers.co.uk I just get taken to the unsecure site without the www, does it take time to work?

0 Likes

#15

That’s really weird… It seems a bit temperamental, sometimes I see the privacy warning and it shows me an invalid cert from the server and other times it redirects me correctly… I am not really sure about that! Maybe someone else can help here :slightly_smiling_face: @sdayman, @matteo @judge? Just because you’re online! :innocent:

1 Like

#16

Works fine for me now…

2 Likes

#17

Thanks @matteo, must just have been propagation, works every time for me now as well :slightly_smiling_face:

2 Likes

#18

Works for me. I was going to check the headers to see what it was connecting to. Everything looks good now.

2 Likes

#19

Thanks a lot guys, i’ll sit tight and hopefully it’ll sort itself out :slight_smile:

2 Likes

#20

This post was flagged by the community and is temporarily hidden.

0 Likes