Your connection is not private error in phone but not in desktop


#1

Today I have enabled Free SSL for my website mytop10series.com, it is working perfectly in desktop but it is not working in the phone, I am using chrome browser on both devices, I had tried on the Android browser but got the same error. What is the problem? Please help !


#2

It’s working for me and shows a valid SSL. (Chrome Mobile). Can you clears your cache for your browser and try again?


#3

you are right, its also working in my friend’s mobile, but even after clearing the cache, its is showing the same error :frowning:


#4

Ok.
What’s the exact error and which Android / Chrome mobile version do you use?


#5

Your connection isn’t private
Attackers might be trying to steal your info from www.mytop10series.com (for example, passwords, messages or credit cards).
NET::ERR_CERT_AUTHORITY_INVALID

i have also tried in Mobile Edge Browser and got the same error.

i am using -

Android 5.1.1
Chrome Version: 65.0.3325.109
Edge Version: 1.0.0.1726


#6

Your SSL setting @ CF is "Full (strict)?
If so, set it back to Full and check again. If the error disappears, there might be something wrong with your server configuration. (Certificate chain for example)


#7

No, it is on “Flexible”


#8

These are some screenshot that maybe helpful to solve this issue.


#9

Thank You So Much @MarkMeyer For Your Help, It is solved now, i just disabled the SSL in Crypto section and re-enabled it, and booom!! its workinng perfectly. Thank You Again For Your Quick Replies.


#10

Your’re welcome. Glad to read, though I didn’t do anything. :smiley:

Little hint:

“Flexible” will only encrypt the traffic between client and Cloudflare. Traffic between Cloudflare and your server remains unencrypted. I highly recommend to enable SSL on your origin, even with a self signed certificate and use at least “Full” SSL.


#11

This topic was automatically closed after 14 days. New replies are no longer allowed.