You have already added this custom domain. (Code: 8000018)

When I try to bind a domain to the Cloudflare page, it prompts “You have already added this custom domain. Select another custom domain or check your project configuration. (Code: 8000018)”

I have tried many times, and I have deleted the domain name and added it again, but the problem still exists.

How to solve this problem?

What’s the domain and the of the project you’re adding to?

I tried it, the second-level domain name ( is fine, but the root domain ( name is not.@Walshy

That is strange…

I see the domain active on that project as of 4 days ago, however, I don’t see it in our DB. I also don’t see any DNS records.

I suspect if you add a CNAME to on your domain, it will work.

I’m gonna look more into the weird state but can you try that so we can get the site working for now?

It’s really really strange, I created a new page, and then tried to bind the domain name mentioned before, the result is actually ok, no error is reported, it’s really a bit inexplicable, like metaphysics.@Walshy