Yet another mail delivery issue?!

Thanks again, changed the NS back to Cloudflare now, and webmail open, here’s hoping :slight_smile:
Marko

1 Like

:+1: May take a while for the change of nameservers to propagate :slight_smile:

1 Like

Yep, that’s cool, I’ll post back tomorrow hopefully once I know the site is routing through Cloudflare with an update.

1 Like

Great, if it stops working again, rather than changing the nameservers back, can you pause Cloudflare on the site and see if it works then, which will help track down where the issue is?

You can pause Cloudflare from the Overview tab of the Cloudflare Dashboard, bottom right under Advanced Actions.

Will do :slight_smile:

1 Like

Think we’ve hit the snag again, just tried logging into my cPanel and timing out trying to connect to our domain:2083 - got through to our webmail via the site providers own route and I am expecting mail but none in the webmail at all. Similarly, and expectedly, nothing coming through via Gmail also. I’ve left Cloudflare active for now because the mails aren’t critical but just wondering where to look next.

As an afterthought, I’m wondering about the CNAME - www pointing to our domain which is proxied?

Also, looking at the analytics, it does appear little traffic is actually going through Cloudflare, but this may just be because the cache is playing catch up?
Cheers
Marko

Cloudflare does support port 2083 when proxied so that would normally work.

Can you send a test email from an account not on that domain to one you are having issues with and let us know if it comes through or if you receive a bounce reply / message?

Mail sent from a separate gmail account to our domain email, nothing at all in webmail and no bounce but I think it would take a little time to bounce, probably if remained undeliverable for 24 hours it would bounce then but I don’t think I could afford 24 hours without mail lol!!

OK, can you pause Cloudflare, give it a short while to propagate and send another test email and see if the result is the same?

You can pause Cloudflare from the Overview tab of the Cloudflare Dashboard, bottom right under Advanced Actions.

Will do :slight_smile:

1 Like

Just received the mail I sent and another one after about 8 minutes of Cloudflare being disabled, still waiting on a few more mails to come but these would have been sent a while ago so I wonder if they are on some kind of ‘hold’ and will come through eventually, sent another test mail from a seperate account and came through instantly, so I’m thinking there is some config issue on Cloudflare stopping mail coming through but you’re a better man than me if you can figure it out lol
NB, a refresh of our gmail just downloaded all the other mails I was expecting now too :slight_smile:

OK, that’s really strange if you got the email you sent when Cloudflare was enabled, when you paused Cloudflare…

If it was a proxy issue, I would not expect the email to come through later unless it was your sending email re-trying to get it through.

Doing some tests and looking into this further…

:+1:

1 Like

Cheers, appreciate the support

1 Like

Just been reviewing the info you provided earlier.

Seeing as your MX records point directly to Krystal and not to a subdomain of your domain name, those shouldn’t be affected by the proxy. Therefore, enabling Cloudflare should not affect incoming mail to your webmail. Are you able to contact Krystal to confirm with them that all is OK at their end and that there should be no issue when enabling Cloudflare?

I will continue checking through this to see if I can spot anything, ad maybe someone else here can help too.

1 Like

No worries, I’ll fire a support ticket in with them to see if they can shed any light and get back to you as soon as I hear anything back from them.
Cheers
Marko

1 Like

Well, the guys at Krystal (who are always quick off the mark) have explained it’s an issue with the “Spam Experts Routing” module on the cPanel, from what I understand we have an “A” record in that module to our domain, when we enable Cloudflare that means the domain.co.uk part for the mail is now trying to send/receive mail through the domain, rather than the IP, etc, so the solution was to update the record with the server hostname instead of our domain, kinda get it in regards to our doman being proxied etc,re-enabled Cloudflare last night and mail is coming through without any issues now, I was trying to reply last night once I noticed things working but because I’m a noob I’m restricted to ## replies per day.
All seems well so far, but thank you for all your help domjh, and possibly another thing for you techies to add to your ever growing list of solutions lol :slight_smile:
All the best
Marko

2 Likes

Thank you for letting us know, @markopolo - glad you got it sorted!

Yep! Thank you very much for the detail on the fix.

2 Likes

Hi again @markopolo,

Just wanted to say thanks again for letting us know what the solution was in detail, I have now updated our tutorial on mail issues that you looked at originally to reflect this :slight_smile:

Not at all @domjh, I wouldn’t have guessed to contact the host as I thought it was purely a routing issue with the Cloudflare setup, so thank you again for your help and the suggestion to contact them :slight_smile:
All the best
Marko

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.