XHR (AJAX) POST Query - status 0 / interruption

Good day! Sorry for my bad english! I have a big problem, the AJAX request is terminated 3-5 seconds after sending, and there is no error, it returns a 404 status, and jqXHR.status = 0, those are connection problems, I suffered, the problem appeared in different browsers in different ways. When you turn off proxying in cloudflare, everything starts working. Help what needs to be done? the request is not cors, everything is within the same domain.

1 Like

I presume that is still on HTTPS then, right? So you can confirm that you have a valid SSL certificate on your server?

I will add that in chrome the error looks like ERR_CONNECTION_CLOSED

Thanks for the answer! I am using Full Encrypt in cloudflare settings, the server has SSL from cloudflare (Universal)

What is the URL which returns that 404?

https://www.bigtv.ru/cart/deliveryPricing

Just pay attention, now proxying is disabled. It’s not that 404 is given, I’ll show you a screenshot right now.

1 Like

The connection is broken after 3-5 seconds, but the server accepted the request and executes it, but the client is disconnected. I checked everything, this is not my mistake, this is clearly something with the settings in cloudflare

When accessing that URL through the proxy I get the same 405 as when connecting directly.

What steps do I have to follow on the page to reproduce it?

  1. www.bigtv.ru
  2. add to cart same product
  3. www.bigtv.ru/cart/
  4. input “Москва” and select suggestion and AJAX query start

But now everything will work, check it out. As you look, I will turn on proxying, and it will stop working.

Took about nine seconds but loaded fine via the proxies

image

1 Like

Thank you for your reply and for your time! So I say, it works, it doesn’t work. In firefox, everything seems to be fine, but in chrome it is not, you send the same request several times and such errors appear as I sent above.

That will be a server issue then however. You need to debug this on your server I am afraid. Cloudflare won’t be involved here, they simply route the request to your server and it obviouly works with Firefox, so the Chrome issue will be your server configuration.

Just tried it on Chrome and it worked too

image

1 Like

Hi, my friend! Sry for bad English…

I find solution!

My real ip: 217.172.21.153
if cloudflare proxy on, my ip on site = 193.106.68.249, real-ip in nginx ON.

))) see this)

traceroute

our provider send me this

Cloudflare ip blocked in russia (https://blocklist.rkn.gov.ru)

How change ip on cloudflare?)))) Help)))

There is not much you can do. Your government needs to stop blocking them. You can use the search here too, as that topic came up quite a few times.

1 Like