Xenforo problems with cloudflare caching

pagerules
caching

#1

I have a Xenforo forum https://www.egyfitness.net/forum/

But CF has big conflicts with the forum :slight_smile:

1 - There are big delays for users replies and posts . If I see a thread with 3 replies , when I open it I cant see all replies unless I click ctrl + f5

2 - I can’t log in to administration page

As per attached picture I tried to exclude /forum/* from caching but this is not working at all . The forum is cached no matter what. I have to put it in development mode so I can log to admin


#2

Update : I paused CF (disabled it) for egyfitness.net

And the problem resolved. I was thinking there is caching going on in my VPS settings , but no , it is cloudflare problem

The page rules I mentioned above are not working and are not excluding my /forum/* from caching


#3

Try making Rule #1 have forum/* at the end. It doesn’t have a * like the others do.


#4

I tried at #3 as u can see…


#5

Yes, but it’s missing the ‘www’. Your site redirects to www. Rule #3 isn’t used.


#6

I changed the rules , but problem persists


#7

It should Rule #1. Just drag it up before your Cache Everything rule.


#8

You’re doing it wrong for cache everything page rules - you do not want to be using cache everything for html pages ! Check out these guides for clues

I have been using Cloudflare for my Xenforo forums without issue https://community.centminmod.com/


#9

You’re getting closer, but the rules are likely in the wrong order for
what you want – You likely want the /forum* entry to be first.

Once it works, you’ll probably not want to stick with Cache Level set to
Bypass although it is good for testing. Normal caching will probably
work once things are otherwise running.

Also don’t forget to clear the cache after re-order the rules.


#10

This topic was automatically closed after 14 days. New replies are no longer allowed.