X10hosting: Child failed to make LIVEAPI connection to cPanel

Using x10hosting service and Cloudflare, when I click Cloudflare icon, I got
“Child failed to make LIVEAPI connection to cPanel.”
The https is still untrusted, please give some advise.

1 Like

Do you have a valid certificate on your server? I seem to remember your host might not offer SSL at all.

Whats the domain?

the domain is www.musoum.com
I think maybe it does not have a valid cert, it probably has one which is x10hosting, I thought we can use the cloud flare’s issued ssl cert ?

Cloudflare only issues a certificate on their edge servers, you still need one on your server.

In free x10hosting, so I am not able to run script, but I do have access to the file manager, is it possible to do this without a script ?

This server could not prove that it is www.musoum.com ; its security certificate is from *.x10hosting.com . This may be caused by a misconfiguration or an attacker intercepting your connection.


Does that mean I don’t have one or it just mean I have one but is not tied to musoum.com ?

Both actually. There is a certificate, but its not yours and hence does not cover your domain. I’d strongly advice to get a proper certificate configured, your only alternative would be to opt for a less secure connection and switch to “Full” instead of “Full strict” on Cloudflare. That would make your site vulnerable to MITM attacks and I’d advise against it.

Then I don’t understand how did it managed to work before (domain was aliothstar.com and cpanel was x3 instead of paper_lantern) ?

What you need is a certificate on your server.

Apart from the certificate, can you post a screenshot of the error? There might be also another issue. Have you made sure you updated everything to the latest version, including the Cloudflare plugin?

If you can’t get your host to install a cert for your domain, you’ll have to set SSL here to Full (not strict).

To me this appears like a version incompatibility


I don’t think I can ask them to install the cert, they are pretty reluctant to help me with anything unless I subscribe to their expensive plan.

I tried setting ssl to Full in Cloudflare, but the website is still “not secure” indicated by the browser. Is there more that I need to configure ?


Time for a better host then.

As for the error, right now you are not using Cloudflare at all, so you get the error because of the invalid certificate.

Yes, I saw this post before asking the community.

The problem with this is that I cannot ssh to the host to fix this, and the host provider refuse to help me with this.

That’s why I need to ask the community for help.


Well, first of all, the certificate is an issue. You should never use an invalid certificate. If your host refuses to assist here, your only option is to find a better host.

However, you also need to establish if that error is actually SSL related or something else. From the description in the link, it might not be, but rather a version issue. The first step should be to clarify this with the Simple SSL guys, as it is them who throw that error in your screenshot.

No wonder the traffic was 0.
I just change my dns name server to the ones assign by Cloudflare, would that be sufficient ? If not, what else do I need to do ?

Please let me know if there is better host out there.

Nameservers are set, but you dont have any DNS records set up.

There are plenty of better hosts out there, but which one is something you will need to research as that depends on your requirements.

Well, you obviously need to set them at Cloudflare.

1 Like

I did that as well, but still does not work