X10host website with cloudflare domain

I have a x10host website (www.christurnbullwx.x10host.com) and I just purchased a domain with cloudflare (www.christurnbullwx.com). I am not sure on how to move the DNS around to get my website to display with my purchased domain rather than the x10host domain. I tried putting Cloudflare’s name servers into the DNS management section on my x10host control panel and added a Type A record on CloudFlare. When I try going to my new address, Safari just tells me the server could not be found. Obviously, I am not doing this right. What am I supposed to do to get this to work? Thanks and sorry if this is a simple question.

Hi @cst2,

Do you have your custom domain set up on x10host? i.e. do they know that domain exists and to serve your site for it?

If so, they should provide you with the DNS records required for your site and you should add these in your Cloudflare dashboard. It will most likely be an A record pointing to their IP or a CNAME to a hostname.

The domain with x10host is a free subdomain (christurnbullwx.x10host.com). All the files for my site are with them. I purchased a domain with Cloudflare (christurnbullwx.com) that I want to connect with my x10host subdomain. I tried putting the Type A record from x10host into the Cloudflare dashboard, but it does not seem to work. I also put the cloudflare name server records into the dns management section back in my x10host cpanel. The cpanel also has an option for domain pointers, but I’m not sure if that would help at all.

Cloudflare

!

x10host
Screen Shot 2021-11-09 at 6.15.35 PM|690x308

You most likely have to use a CNAME record, but that’s up to X10 to configure and tell you what your CNAME should look like.

I sent a message in the x10host forum. I’m not doing this right. The CNAME in my dns management just says www for the name and christurnbullwx.x10host.com for the name. When I try visiting christurnbullwx.com, all I get is “apache is functioning normally.” I tried changing my WordPress address and site address both to https://www.christurnbullwx.com from the original https://www.christurnbullwx.x10host.com, but that also did not work.

I would suggest you toggle both of those to be :grey: DNS Only, then make sure one or the other (or both) functions with HTTPS.

Once you get one (or both) working, you might consider a Page Rule to redirect one to the other:
Match example.com/* and a Forwarding URL (301) setting to https://www.example.com/$1

Turning both of those to DNS Only resulted in the following when I set the wordpress site address to https://www.christurnbullwx.com.

You shouldn’t see Cloudflare messages in DNS Only mode. Make sure you give DNS five minutes to update.

So now I got a message from Safari saying that this connection might not be private. I allowed it, but then it brought me back to the “Apache is working normally.” That apache message also comes up if I do not type in the https://. Safari just has a message in the url bar saying that it is not secure.

If you can’t get this to work, you need to ask X10 for assistance. Cloudflare isn’t going to work if the hosting doesn’t work on its own.

1 Like

I was advised to add the purchased domain christurnbullwx.com to my x10host domain setup panel, which I did. I then added the x10host name servers to my cloudflare dashboard and the cloudflare name servers to my x10host dns management for the domain. I then moved my files over from the free christurnbullwx.x10host.com folder to the newly added christurnbullwx.com folder. Unfortunately, that still doesn’t work. I also tried suspending my christurnbullwx.x10host.com domain to see if that would do anything. That did not.

Going to http://www.christurnbullwx.com gives me: “Apache is functioning normally”
Going to https://christurnbullwx.com results in a timeout
Going to https://www.christurnbullwx.com or https://www.christurnbullwx.x10host.com results in a 403 Forbidden page.



the x10host link shows forbidden, but the rest of your links show something like this:

I solved it. I needed to delete the x10host name servers from the x10host dns management, and add the origin ssl certificate to the x10host ssl certificates section. I also realized I mistyped the IP address for the Type A records in the cloudflare dashboard. That has been corrected. I also needed to delete the default index.html page that was created when I added the domain in the x10host domain setup page. Now the homepage works as well as the other pages. Now I just need to redirect the http://www.christurnbullwx.com to the https:// so that users don’t get the ‘apache is functioning normally’ text.

EDIT: got that last part working. Needed to do a force redirect back in the x10host settings to get rid of that apache is functioning normally. I also turned on the always use https option on my cloudflare dashboard.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.