X-Robots-Tag Setting


#1

Hello,

I have a WordPress site that is not setting the X-Robots-Tag anywhere - yet it is appearing in the Response Header of the website as:

X-Robots-Tag: noindex, nofollow, nosnippet, noarchive

We are using CloudFlare - is it possible that there is a setting in Cloudflare that I need to turn off so that the website is discoverable by Search Engines?

Many thanks,

Alexis.


#2

This guy was also sure that it’s not from his server: Noindex sent to Google crawling bot (I’m not saying you’re wrong, I’m saying you might be wrong)

Did you check directly with your server or with Cloudflare temporarily off? (click the orange cloud, wait 10 minutes, then check again? Assuming you’re either not with SSL or your original site also has SSL - because if the answer is “no” to any of these - don’t disable Cloudflare as your client might not be able to connect anymore- just test directly - e.g. by putting your original IP with the FQDN in your OS’ hosts file, restarting the browser, then checking again)


closed #3

This topic was automatically closed after 14 days. New replies are no longer allowed.