X-Proxy-Cache: HTTP Header Always Says "MISS"

siteground
cache
#1

Hi there!

Perhaps someone in this community can help solve our issue …

With Cloudflare “On”, our website’s HTTP Header says “X-Proxy-Cache = MISS” and “CF-Cache-Status = HIT”

With Cloudflare “Off” or “Development Mode”, our website’s HTTP Header says “X-Proxy-Cache = HIT” and no CF-Cache-Status listed.

Above results provided by: https://www.webconfs.com/http-header-check.php

In short, it appears Cloudflare is blocking our origin server (back-end) and not allowing it cache our files.

We use SiteGround’s SG Optimizer plugin and WP Rocket. Yes, we performed the usual “all plugins deactivated test” except for SG Optimizer and still have the same problem.

We have also contacted both Clodflare and SiteGround customer support, but they have been unable to solve the issue.

Has anyone experienced this before? What was your solution?

Thank you!

0 Likes

#2

My only idea is that it has something to do with your origin’s cache key using the request header Cf-Ray, which would be really odd. Nothing else should change in between requests assuming it’s a GET to the same file every time. Do you know if you ever configured something like that in the plugin or with Siteground?

0 Likes

#3

Hi @Judge,

Not sure I understand but, to me more specific, here’s what our headers look like. Also, should point out that we have a Cloudflare plan provided by SiteGround with Cloudflare’s Railgun service enabled.

After looking at our headers, any other “theories” on what could be causing the problem?

Thank you!

0 Likes

closed #4

This topic was automatically closed after 30 days. New replies are no longer allowed.

0 Likes