Www version is giving a connection not private error page

If you visit the non-www version of my domain, browncreativegroup.com, it loads correctly.

However the www version, www.browncreativegroup.com, gives a “your connection is not private” error. How do I fix?

Thanks!

Those are two different certificates. That’s usually difficult to make happen.

It looks like you’re paying for a Dedicated certificate for the root domain, but have an expired HubSpot certificate issued by Cloudflare for the www.

Take a look around your SSL/TLS settings page at the certificates you have set up for your domain in the Edge Certificates section.

1 Like

I just signed up for the $5/mo certificate today in hopes that it would help fix things. I used to have my website on the HubSpot CMS but no longer have HubSpot anymore.

Here are my SSL/TLS settings. Most of this is Greek to me though.

How should I have it set so that both www and non-www load the site correctly under https?

Go to the very bottom of that screen and click Disable Universal SSL. That will force Cloudflare to use your Dedicated certificate. Hopefully that will fix it.

OK I disabled it - so far I’m still not able to load the non-www. Can you confirm? https://www.browncreativegroup.com

Did that Universal (Shared) certificate drop off your list?

If so, the two options I’d recommend would be to 1) Contact Support, or 2) Delete that Dedicated certificate and re-issue it. I’d go with Option 2 with the optimistic hope it’d fix it. Plan 2b would be to delete the Dedicated Certificate and then re-enable Universal SSL.

Clearly the certificate that’s there now is broken (expired). One way or another it needs to be deleted and re-issued.

This topic was automatically closed after 30 days. New replies are no longer allowed.