WWW Redirect on Commodore.ca

I want all traffic to Commodore.ca to be redirected to www.Commodore.ca so I read a few posts and created the following PAGE RULE:

commodore.ca/
Forwarding URL (Status Code: 301 - Permanent Redirect, Url: https://www.Commodore.ca/)

Unfortunately it is not working. If you surf to https://commodore.ca/robots.txt it will come up. I would like it redirected to https://www.commodore.ca/robots.txt

BACKGROUND:
I have SSL/TLS set to FULL
I have SSL/TLS > EDGE CERTS set to ALWAYS USE HTTPS

Am I missing a wildcard * or doing something silly?

Thoughts?

Try

commodore.ca/*

2 Likes

Wonderful.

The page you referenced had a link to exactly what I needed Redirect example.com to www.example.com and now all is working as expected.

Thanks for the help. @MarkMeyer

2 Likes

Shocker… I missed something. Now my FTP.COMMODORE.CA is failing in FileZilla. I checked a several other threads and goofed with some options, but none resolved my issue.

To access my FTP, I just used the IP address but that is a pain.

Is there a straight foward work around for this?

FTP is not proxied by Cloudflare. You either need to use your IP address to connect or switch ftp. to DNS only. (:grey:)

This will reveal your IP

Ha! I had turned PROXIED on a few weeks ago just to clear the BANG on the DNS.

In case anyone else is reading this for a similar problem, it also occured to me that you could create a page rule for FTP that runs BEFORE the redirect page rule and then stops processing… just a thought

Thanks @MarkMeyer . Super appreciated :slight_smile:

1 Like

Ok… Here is an annoyance I had not thought of: Because these sites have been around since the 1990’s there are many internal links that go to HTTP and not HTTPS (mostly from the days before WordPress and Content Management Systems). That means I am now seeing Google errors about bad links:

http://www.commodore.ca/wp-content/uploads/2020/01/Commodore-dot-ca-black-360x50-1.jpg Image Redirection error”

“Mixed Content: The page at ‘https://www.commodore.ca/arcade/amp/’ was loaded over HTTPS, but requested an insecure image ‘http://www.commodore.ca/wp-content/uploads/2020/01/Commodore-dot-ca-black-360x50-1.jpg’. This content should also be served over HTTPS.”

I think there is no ready way for me to correct tens of thousands of links on dozens of websites. At least no ready way that isn’t going to blow another weekend of effort and return very little in performance and ranking improvements.

As such I think I have to remove the d#$m rule.

Thanks all the same. @MarkMeyer

This will not have the desired outcome. Hostnames used for ftp must be :grey:.

You cannot connect to Cloudflare IP addresses with an FTP client unless you are paying for Spectrum, which is unlikely in almost every situation.

Turn on Automatic HTTPS Redirects. This should resolve most mixed content warnings on your site.

Real Media streaming included. That takes me back to when I had more hair!

Hi Michael;

My FTP is working fine now with out being proxied and I have had AUTOMATIC HTTPS REDIRECTION turned on for a very long time. Oh well, it looks like I will just have to put up with hard links to HTTP for a while yet.

Thanks all the same.

Hi @calgarytech,

I think Automatic HTTPS Rewrites was possibly what @michael meant for mixed content. Do you have that enabled as well? It’s on the same page as the Always Use HTTPS setting.

Yes, that is what I meant. (Error between keyboard and chair!)

1 Like

This topic was automatically closed after 31 days. New replies are no longer allowed.