Www not working only https:// or http://

Hi there my site keeps getting error when i try login the website with www.marketinginstitute.com

but it works fine with https://marketinginstitute.com/ and http://marketinginstitute.com/

but when www. is added like https://www.marketinginstitute.com/ or http://www.marketinginstitute.com/ an error happen

Is there something in cloudflare setting i should fix or amend

As both are added in DNS

Seeking your assistance

Thanks

From the above screenshots, DNS records are correctly setup.

Furthermore, the screenshot showing “404 not found” comes from the origin host/server, or rather due to the “route path” configuration of your Web application.

You’ve setup www to use for login or?

I do see you’ve restricted some access-control by HTTP headers so far.

What happens when you temporary enable the Pause Cloudflare for this site option, or rather switch from :orange: to :grey: (DNS-only)?

1 Like

Hi there Fritex thanks for your answer,actually i am using a site for building my landingpage and as you can see the error is showing their logo

Can you explain to me the access control by HTTP headers, as i am using one site for funnels and landingpages and other site for learning platform.can you elaborate about the (Pause Cloudflare ) and Http headers

or do you mean this

or do you mean this

I have turned it off still nothing happened ,same issue

no i am not intenting using www. for login i just want people to be able to login to site as not all people loging such as https//-----

Will it impact the SEO or as long it is forwarded to https: it is better for google and is there a way to do it without forwarding because what i can see from the host provider that offer the landing page they say we have to do it forwarding for it to work, meaning technical issue from their side

https://phonesites.com/training/www-forwarding

Hi there my site keeps getting error when i try login the website with www.marketinginstitute.com

but it works fine with https://marketinginstitute.com/ and http://marketinginstitute.com/

but when www. is added like https://www.marketinginstitute.com/ or http://www.marketinginstitute.com/ an error happen

Is there something in cloudflare setting i should fix or amend

As both are added in DNS


Seeking your assistance

Thanks

I was only able to fix this by forwarding permenantly

Will it impact the SEO or as long it is forwarded to https: it is better for google and is there a way to do it without forwarding because what i can see from the host provider that offer the landing page they say we have to do it forwarding for it to work, meaning technical issue from their side

https://phonesites.com/training/www-forwarding

I am quite surprised why is this happening and sorry you are experiencing this issue.

I think not.

As far as running below search query into the Google search gives me 0 results indexed (www):

site:www.marketinginstitute.com

While for below one I get few pages indexed (non-www):

site:marketinginstitute.com

You can always have redirection from non-www to www, or vice-versa.

The important part is which version of the URL is added to the <link rel="canonical"> HTML tag / HTTP header and which URLs have been submitted to Google Search via your sitemap.xml file in the Google Search Console interface:

Nevertheless, your robots.txt file contains:

https://marketinginstitute.com/sitemap.xml

Which I am not sure if that’s a valid Sitemap?
Kindly, scan and replace your sitemap file using some online tool like at the link from below:

Should look like below:

<?xml version="1.0" encoding="UTF-8"?>
<urlset
      xmlns="http://www.sitemaps.org/schemas/sitemap/0.9"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xsi:schemaLocation="http://www.sitemaps.org/schemas/sitemap/0.9
            http://www.sitemaps.org/schemas/sitemap/0.9/sitemap.xsd">
<url>
  <loc>https://marketinginstitute.com/</loc>
  <lastmod>2022-01-02T13:35:02+00:00</lastmod>
</url>
</urlset>

In terms of HTTP<->HTTPS, there is a working redirection from HTTP to HTTPS, so you are fine with it.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.