"www.mathforschool.xyz redirected you too many times"

So ive recently setup a site on Cloudflare, running from google sites, and the domain from namecheap, and when the ssl level is set to “flexable” it gives me a error when loading the site saying it is redirected to many times, but if i put it to “Full” or “Full Strict” it saids “525 SSL Handshake Failed”

Greetings,

Thank you for asking.

Did you get this error on a naked-domain or a sub-domain? :thinking:

Regarding Cloudflare 525 error, may I ask which suggestions from below article for have you tried for further troubleshooting? :thinking:

Before moving to Cloudflare, was your Website working over HTTPS connection with a valid SSL certificate? :thinking:

Kindly, before doing anything at Cloudfalre settings, you could determine if you have a valid SSL certificate installed at the origin host/server by your web hosting provider or your own VPS/dedicated server following the steps from below:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.
  4. Check with your hosting provider / cPanel AutoSSL / ACME.sh / Certbot / Let’s Encrypt or some other and renew it accordingly.
  5. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

1 Like

Yes my site worked fine, and i have currently set to " Full Strict

Is know for issues like mixed content or redirect loops and not a recommended at all. More about this SSL mode can be read at the article below:

1 Like

ok. but i dont have it set to flexable

Thank you for feedback information.

However, follow the “Pause” steps from above to double-check and determine if your origin SSL certificate is still a valid one, if not, make sure to renew it as seems it’s needed as far as you’re getting that kind of an error message, upon success “un-pause” and set to Full Strict :thinking:

ive already done it

I cannot test it due to being presented with 1020 Access Denied page from your custom-made Firewall Rule. Kindly, disable it temporary so I could troubleshoot further.

You might have an issue of redirecting from www to non-www or vice-versa :thinking:

Nevertheless, you’r missing an naked-domain DNS record A mathforschool.xyz, therefore the Web browser shows another error, while the A www is existing at the DNS tab of Cloudflare dashboard for your domain name.

Kindly, add it using the step-by-step instructions from below tutorial:

I disabled the firewall

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.