Www is not enabled on SSL

I enabled Cloudflare just to redirect my site from www.ssdo.org.pk to ssdo.org.pk but when I entered www.ssdo.org.pk instead of ssdo.org.pk it shows me the message not secure.
my records that are proxied are as follows

Maybe the SSL certificate didn’t renew and/or cover the www prefix? :thinking:
Meaning www is HTTP-only while example.com is secured? :thinking:
Maybe the SSL certificate expired and needs to be renewed? :thinking:

Before moving to Cloudflare, was your Website working over HTTPS connection?

I’d suggest you to determine if www is covered and in case if needed, renew it by follow below steps:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS without any error
  4. Check with your hosting provider / cPanel AutoSSL / Let’s Encrypt / Certbot / ACME and renew it in case if needed
  5. Only then, when your website responds over HTTPS, you should un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

Nevertheless, you could point A www to the temporary IP address like 192.0.2.1 and then create a Rule to redirect from www to non-www. No need to renew the SSL certificate for www, if so (but better way to renew www).

Kindly, make sure the DNS records are proxied and :orange: .

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.