Www gets 522 Error In Newly Transferred Domain

I recently transferred my domain to cloudFlare the domain has been fully transferred … I can get to my site if I enter “playmoneytrain.com”…but… When I try to access “www.playmoneytrain.com)”, I get a 522 error (message attached).

Initially, I was getting a redirect timeout error so I reviewed the dns records and noted that the www alias was pointing to a Dreamhost server. (Dreamhost was my previous hosting service.) I made a change to the dns records but I am still not able to access the site with www.playmoneytrain.com. I have attached a screenshot of the current dns records for my site.

Please let me know if you need additional information.

Thank you for the assist! Cheryl

Attachment(s)


I guess you’ve not added the www subdomain to your Pages project. Adding it should resolve the problem – but then you’ll have duplicate contingent issues (if SEO is important to you).

So redirect www to the apex domain instead.

Thank you for your reply. I’ve reviewed the information (links) you’ve sent and it does seem like this will resolve my issue. One (likely dumb) question… It looks like I can add the bulk redirect list and redirect rule (per the documentation), without impacting the workings of the current URLs… Is that correct? I mean that even if I don’t get this entered correctly the first time, the “playmoneytrain.com” URL will still work… right?

Thanks again for your help with this!! Cheryl

Hello! I followed the process provided in the previous reply and was able to successfully create a bulk redirect… and… it worked!!! Thank you so much for the assist! Cheryl

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.